1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't initialize micro sd card

Discussion in 'Zgemma-Star H.2S' started by Dee-Dee, Dec 10, 2016.

  1. Dee-Dee

    Dee-Dee Registered

    48
    0
    Okay I already have my box setup how I want and of course my brother wanted the same box. I have got him the same box and flashed the latest wooshbuild on it which went fine. I have a 1tb hardrive connected at the back which is setup for recordings and works fine. The problem I have is the micro sd card, I have it inserted at the side of the box and I am trying to set it up for epg/timeshift but it wont initialize.

    I have formatted the sd card to ex2 using minitool partition wizard, but when i try to initialize the sd card on the box i get the following error

    inttialising storage device... error: timeout elapsed sorry

    I have also formatted the drive to ntfs and still the same, so i am out of clues here
     
  2. Willo3092

    Willo3092 TK Veteran Forum Supporter

    3,548
    1,037
    Initialising the drive means it is converting it to NTFS. Because you've already done it on your PC, you don't need to initialise it on the box, it should just work.
    If you're on ATV check Menu > InfoPanel > Plugins > Mount Manager and see if it's listed as Ext4 R/W - If it is you're okay and good to go.
    If not, format it on the PC again and then put it in the box without initialising.
     
  3. Dee-Dee

    Dee-Dee Registered

    48
    0
    I tried that the first time without doing the initializing of the card when it was formatted to ext 2 on the laptop, but when i tried to setup the timeshift i got the following error when trying to switch the timeshift setting to the sd card

    The directory /media/hdd/timesshift is not writable make sure you select a writable directory instead

    Also its listed as Ext4 R/W in the mount manager. Do these boxes work with 64GB SanDisk Ultra microSD SDXC UHS-I memory card?

    ---------- Post Merged at 04:15 PM ----------

    20161210_161222.jpg
    This is what I see in my mount manager

    20161210_161826.jpg
    This is what I get when switching timeshift location
     
    Last edited: Dec 10, 2016
  4. Willo3092

    Willo3092 TK Veteran Forum Supporter

    3,548
    1,037
    Both devices are mounted as /media/hdd

    You need to change the mountpoint of the sd card. (also showing as 32Gb, is that right?)
     
  5. Alien Heads

    Alien Heads TK Veteran

    621
    37
    When i use an sd card i mout it as /media/mmcblk0p1
     
  6. Dee-Dee

    Dee-Dee Registered

    48
    0
    Okay I have switched the location of sd card to location/media/mmcblk0p1

    but now i get this error message when switching the timeshift location to mmcblk0p1

    20161210_164816.jpg

    The timeshift works but when I restarted my box i get that error message too. The card is formatted to ext2.
     
    Last edited: Dec 10, 2016
  7. Willo3092

    Willo3092 TK Veteran Forum Supporter

    3,548
    1,037
    Did you change the timeshift location to the sd in timeshift settings?
     
  8. Dee-Dee

    Dee-Dee Registered

    48
    0
    Hi willo yes I did.

    Okay I am beginning to think it could be the 1tb Toshiba external hardrive causing this problem.
    View attachment 20966
    On this pic here you see the 1tb usb external drive under the size it states device: /dev/sda1 but the mount is /media/hdd

    I have changed the external mount to dev/sda1 but as soon as I press the red button to click use as hardrive it sticks it back to /media/hdd
     
  9. Willo3092

    Willo3092 TK Veteran Forum Supporter

    3,548
    1,037
    The HDD should be /mediahdd
    The microsd should be /media/mmcblk0p1

    Don't worry about the devices bit. You only need the filesystem mounts to be as above.
     
  10. Dee-Dee

    Dee-Dee Registered

    48
    0
    Well I don't know whats happening than, might have to reflash and start from scratch. In mount manager do i have to click the red button use as a HDD with the micro sd card or is it just for the 1tb external hardrive?
     
    Last edited: Dec 10, 2016
  11. Willo3092

    Willo3092 TK Veteran Forum Supporter

    3,548
    1,037
    Do a settings and image backup. Flash Wooshbuild without doing anything to the HDD or microsd and see if you can change timeshift to microsd.
    If you can, it's a problem in the settings. If you can't it's a problem with the microsd card.
     
  12. Dee-Dee

    Dee-Dee Registered

    48
    0
    Okay changing the timeshift settings to the 1tb drive and removing the micro sd completly and restarting i get the same error so its not the micro sd. The thing is timeshift works on both drives, but this error message is peeing me off. Its coming up for a reason and every time on bootup.
     
    Last edited: Dec 10, 2016
  13. Snapper93

    Snapper93 TK Veteran

    1,130
    4
    You need to convert the sd card to ext3/4 and thentell box you want to use it as HDD. Try red button plugins mount manager
     
  14. Dee-Dee

    Dee-Dee Registered

    48
    0
    Your confusing me now. The error message states it has to be in ext2 and 3 not 3 and 4, plus pressing the red button to use my micro sd card as a hdd just changes the mount path to media/hdd.
     
  15. Willo3092

    Willo3092 TK Veteran Forum Supporter

    3,548
    1,037
    It can be Ext 2,3 or 4. You do not want it to be /media/hdd it needs to be /media/mmcblk0p1
     
  16. Dee-Dee

    Dee-Dee Registered

    48
    0
    Okay so i took out the micro sd card and reinitialized the 1tb drive while re-flashing with wooshbuild. The flash was fine and timeshift and recordings work when using the 1tb drive and no error message during startups. As soon as i put the micro sd card in and try to use that for timeshift i get that error message but timeshift still works. Whats confused me is I took out the micro sd and put the timeshift settings back to the hardrive and rebooted and guess what i get that error message still, but timeshift still works???????

    Where do i go from here?
     
  17. Willo3092

    Willo3092 TK Veteran Forum Supporter

    3,548
    1,037
    I said to leave the microsd where it was and then flash Wooshbuild to test it.
    Just click 'no' on the initialisation page.