1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Got 4K content but won’t play?

Discussion in 'Kodi - Android box - Firesticks - MXQ' started by userlee5267, Sep 15, 2018.

  1. userlee5267

    userlee5267 Registered

    359
    43
    28
    hello

    Got a good American server with loads of 4K films. Got 45mb internet connected by ethernet and they are stop start stop start. And some fail to play. I have a 4K tv and a tx3 mini whisk says plays 4K which I’m doubting
     
  2. allrounder55

    allrounder55 Registered

    185
    26
    28
    Male
    {Reselling of electrical items, Laptops, PC's
    Manchester
    i installed the same box on a friends broadband played some vod, picture was amazing he has samsung 4k tv wasnt even a 4k stream but it upscaled the picture so sounds like it could be your provider you need 25meg for 4k which you have easily, try on youtube theres 4k demos if it runs them its the server, If its still stop start then its your internet. Your internet service provider could be choking your bandwidth virmin m do this a lot.
     
  3. userlee5267

    userlee5267 Registered

    359
    43
    28
    Are the YouTube videos actually 4k as the picture settings only go upto 1080p?
     
  4. userlee5267

    userlee5267 Registered

    359
    43
    28
    The YouTube video works. They look good. I’m sure there only 1080 p though
     
  5. allrounder55

    allrounder55 Registered

    185
    26
    28
    Male
    {Reselling of electrical items, Laptops, PC's
    Manchester
    you can change the settings where it says HD it goes to 4k try this link
     
    userlee5267 likes this.
  6. allrounder55

    allrounder55 Registered

    185
    26
    28
    Male
    {Reselling of electrical items, Laptops, PC's
    Manchester
    i just cranked my settings up and was getting slight buffering on 37 mps
     
    userlee5267 likes this.
  7. userlee5267

    userlee5267 Registered

    359
    43
    28
    Getting 45mb and it’s buffering. It’s gotta be shite internet as in drop outs or summat.
     
  8. allrounder55

    allrounder55 Registered

    185
    26
    28
    Male
    {Reselling of electrical items, Laptops, PC's
    Manchester
    it has to be a constant 25 mps or higher or 4k