1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hi Guest, If you haven't already please like our Facebook Page. We post Discount Codes for the Major online retailers. We saved members a fortune over Xmas and continue to post amazing discounts for everyday items. You need to add us to see what i'm taking about. CLICK HERE - click LIKE, add us to "SEE FIRST". So you don't miss expiring codes.

Skybox F5 - Opening serial port is failed??

Discussion in 'Skybox F3 - F5 - F6' started by Robf23, Mar 28, 2015.

  1. Robf23

    Robf23 Registered

    45
    10
    8
    Male
    Hello,

    I'm trying to flash my Skybox F5. The great guides that I found on these forums have been really helpfull however they have only got me so far. I've got all the right files and have a serial RS232 Null Modem Cable.
    I've tried running the Erom Program on both Win7 & WinXP but constantly get stuck on STEP2 of the guide and get the message "Opening serial port is failed" "COM test error".
    I've looked on device manager and under ports all I have is Communications Port (COM1) & Printer Port (LPT1). And when I run the Erom Program the program will only start if I select Port1.
    It's like the program realises when the Skybox gets switch on but can't download any data.
    I'm completely out of ideas so any help will be very much appreciated.

    Kind Regards!
     
  2. the reaper

    the reaper VIP Member Forum Supporter

    4,581
    774
    133
    Male
    {Satellite consultant [retired]
    Mosta, Malta / Essex UK
    If you only have 1 port [com 1] then the erom tool should recognize it. If using a desktop with xp then when in device manager check that com 1 is running/working ok and run troubleshoot to ensure drivers up to date.
    Windows 7 doesn't really like the erom tool as it was designed for xp.
    Ensure you have the correct downloaded copy of Erom Upgrade tool and firmware.
    Ensure box power is off.
    Connect null cable to pc and box.
    Open erom program.
    Ensure com1, even,115200, upgrade showing.
    Enter your f/w
    Press next.
    Power on box when wording--reset target --appears.
    Word--done should appear in r/h/top.
    Then proceed as instructions on screen.
    Reaper.