1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Static IP Settings

Discussion in 'Kodi - Android box - Firesticks - MXQ' started by rpidemon, Sep 28, 2018.

  1. rpidemon

    rpidemon TK Veteran Forum Supporter

    518
    251
    103
    28.2e
    INTRO
    After recently purchasing a Formuler z7+ box, un-boxing it, setting up all the relevant connections, logging into my IPTV in excitement disappointment hit me a message on screen saying no Internet :poop:
    PROBLEM
    At first I thought the box was faulty, then that the ethernet connection and WiFi been connected at the same time was causing a conflict on the network somewhere but this was not the case as the problem still occurred with the WiFi turned off in the Android settings.
    After having a poke around on the Internet it appears to be a common problem not just with the Formuler box but Android boxes in general.
    SOLUTION
    Head for the Android settings and enable static IP and change the following:
    IP address - 192.168.0.250 (as far as I aware the 250 at the end is the highest number you can go to)
    Subnet mask - 255.255.255.0 (standard for ethernet connections)
    Gateway - 192.168.0.1 (this Is your routers IP and may differ between providers)
    First DNS - 90.207.238.97
    Second DNS - 90.207.238.99
    (DNS will differ depending on your provider see below)
    Save the settings and reboot your box.
    BT:
    62.6.40.178
    62.6.40.162
    194.72.9.38
    194.72.9.34
    194.72.0.98
    194.72.0.114
    194.74.65.68
    194.74.65.69
    Plusnet:
    212.159.13.49
    212.159.13.50
    212.159.6.9
    212.159.6.10
    SKY:
    90.207.238.97
    90.207.238.99
    Talktalk:
    62.24.134.1
    62.24.243.2
    VM:
    194.168.4.100
    194.168.8.100
    if the above have no effect, thanks to @ASHHBI for the info.
    Google:
    8.8.8.8
    8.8.4.4
    RESULT
    The box has not lost its connection since and it also improved the speed not by much mind only a few mbs but in a Internet hungry house that can make all the difference.
    Hopefully this will help other Android users who think they have a faulty unit or a problem with their Internet provider/IPTV supplier and maybe even add a few extra mbs to there box.
    This might not be useful for all but certainly helped me out as I would of returned my shiny new box if I had not of set the static IP, taking a couple of minutes out to adjust a few settings can save a whole lot of frustration.
     
    Last edited: Oct 27, 2018
  2. goose1

    goose1 TK Veteran

    1,913
    377
    107
    Male
    good post above rpidemon :thumbsup:
     
    rpidemon likes this.
  3. rpidemon

    rpidemon TK Veteran Forum Supporter

    518
    251
    103
    28.2e
    Thanks you hope it helps a few people out.
     
  4. steptoe

    steptoe TK Veteran

    2,632
    1,050
    133
    Male
    {Electrician
    NW England
    is this a set-up for VM.?
    I think most providers IP range uses 192.168.1.xxx as opposed to you having 192.168.0.xxx
    personally I find the best thing to do is set your router to start DHCP addressing at something like 192.168.1.50 and then have all your fixed devices on static IPs less than 50
     
    stuss and rpidemon like this.
  5. rpidemon

    rpidemon TK Veteran Forum Supporter

    518
    251
    103
    28.2e
    My broadband provider is Sly UK @steptoe thanks for the tips. As I said it may not help everybody but it is a solution that worked for me.
     
    Taylerlee, stuss and steptoe like this.
  6. grahamer67

    grahamer67 TK Veteran Forum Supporter

    1,101
    347
    103
    Male
    {maintenance
    belfast
    Great bit of advice, as it turned out, it worked a treat for me.
     
    rpidemon likes this.
  7. stuss

    stuss TK Veteran Forum Supporter

    853
    628
    133
    Male
    {engineering
    uk
    rpidemon likes this.
  8. ASHHBI

    ASHHBI TK Veteran

    874
    144
    83
    Male
    Lots of people advise to use google dns of 8.8.8.8 and 8.8.4.4
     
    rpidemon likes this.
  9. Taylerlee

    Taylerlee Registered

    248
    134
    43
    Male
    {Retired
    Lancashire
    Rpidemons solution worked for me after having weeks of problems with a sly q router constantly disconnecting. Thanks again.
     
    rpidemon likes this.
  10. rpidemon

    rpidemon TK Veteran Forum Supporter

    518
    251
    103
    28.2e
    Always worth a try, as the guide says this might not work for some but worked for me I assume they are Android specific dns. Thank you for the feedback those who have tried the above.
     
  11. Jethro

    Jethro Registered

    238
    64
    28
    Male
    Will it work on vm as my android box Internet keeps losing connection on the modem,if I turn modem off for a few minutes then power back up it connects again but it's getting a bit of a pain. ?
     
    rpidemon likes this.
  12. rpidemon

    rpidemon TK Veteran Forum Supporter

    518
    251
    103
    28.2e
    I would certainly give it a try the dns settings from VM are in the post so you have nothing to lose.
     
    Jethro likes this.
  13. Jethro

    Jethro Registered

    238
    64
    28
    Male
    Thanks m8, will try it later.
     
  14. rpidemon

    rpidemon TK Veteran Forum Supporter

    518
    251
    103
    28.2e
    Thank you please let us know the result.
     
  15. scouse645

    scouse645 Registered

    186
    13
    18
    {watching TV
    northants
    Thanks, it worked fine for me, the last half hour anyway, i have sly broadband also.
     
    rpidemon likes this.
  16. rpidemon

    rpidemon TK Veteran Forum Supporter

    518
    251
    103
    28.2e
    Post updated with @ASHHBI info provided above. Thank you
     
  17. ASHHBI

    ASHHBI TK Veteran

    874
    144
    83
    Male
    Google dns works with any device. It is not specific to android..
    All my devices including router, TVs, boxes and phones are all on google dns.
     
    rpidemon likes this.
  18. Jethro

    Jethro Registered

    238
    64
    28
    Male
    I am not very technical but do I do these settings once I log in to my router, I don't want to sound too thick ??.
     
  19. rpidemon

    rpidemon TK Veteran Forum Supporter

    518
    251
    103
    28.2e
    Do them in the Android settings on your box mate
     
    Jethro likes this.
  20. Jethro

    Jethro Registered

    238
    64
    28
    Male
    All sorted thanks,will see how it runs later cheers for the info m8.
     
    rpidemon likes this.