HDD locked after BSOD

evh5150

Newbie
Hi,

When I was trying to delete some recordings from my Star 2S yesterday, it rebooted several times after blue screen of death. When it restarted, in my File List there were no recordings, and stated "OSError - please reload list (EMC Menu). I turned off the 2S, pulled the HDD out of the back of it, and put it immediately back in. After this, there are no recordings listed in my Filelist, but there is no OSError either. When I tried to run the FileSystem check in the menu, I get the error "Disk write-protected; use the n-option to do a read-only check of the device". The HDD also shows as having no storage space left and will not record anything.

I realise I could probably initialise my HDD and fix this, but I would like to keep the recordings if possible. Does anyone know what has happened here, and how I can fix it, please?

I'm running OpenATV 5.3, Slyk 1 HD v4.003, and Wooshbuild v.4001 Beta.
 

asmad

TK Veteran
Go to mount manager, setup mounts and ensure your hard drive is set as media/HDD.

Then a reboot should have it working again as normal.
 

evh5150

Newbie
Thread starter
Go to mount manager, setup mounts and ensure your hard drive is set as media/HDD.

Then a reboot should have it working again as normal.

Forgive me for not knowing exactly where I'm going here. I can get to Menu - System - Network - Mount Setup but a lot of this seems to refer to mounting from the network? I can't see exactly where to ensure the HDD is set up properly. Thanks!
 

asmad

TK Veteran
Press blue button to enter quick launch menu.

Scroll down to mounts and select device manager.

Highlight your HDD and press green to setup mounts.

Highlighting your drive press right on the circle button to change display to /media/hdd and press green to save.

Exit button once to enter mount manager and highlight your drive and press red button to use as HDD.

Exit out and long press on power button and select reboot.

Once it's rebooted it should be good again.
Just check your recording and Timeshift are set to media/HDD/movie and media/HDD/Timeshift

You really should upgrade to wooshbuild v5 as v4 is no longer supported and an update will brick your box.
 

evh5150

Newbie
Thread starter
Thanks. The settings you mentioned do need changed, but even when I select /media/hdd and press green to save, after a reboot it has reverted to /media/sda1. I think this is because the HDD is locked (or so it says in the Filesystem check on the 2S). How do I unlock it?
 
Last edited:

evh5150

Newbie
Thread starter
I'd prefer to keep the recordings if possible, but if it comes down to it, I'll initialise and lose them. Thanks for your help.
 
Top