HDMI CEC

dt99

TK Veteran
HDMI CEC doesn't seem to work correctly on these boxes. When I had an H2s I had it all setup so that when I switched the TV on it automatically switched to HDMI 1 which is the input I use for my box. I have the Formuler F1 connected to the same input and all HDMI CEC settings are the same, but when I switch my TV on, it automatically connects to my TV aerial input and I have to keep manually changing the TV to HDMI 1......cant find any setting in the TV options either to stop this.

The only way round it is to leave the F1 box switched on all the time and never put it in standby.

Anyone else have a similar problem, the TV is an LG Smart TV WebOs if that helps.
 

Willo3092

VIP Member
Forum Supporter
I've got 2 smart TV's and there is a setting in the input section to detect connected devices, is there anything like that on the LG?
 

dt99

TK Veteran
Can't find anything like that in any settings option. I even took the aerial out of the tv but when it switches on it still goes to aerial but just has the blank screen.
 

Willo3092

VIP Member
Forum Supporter
Don't know if this helps:

Using SIMPLINK
SIMPLINK allows you to control various multimedia devices so you can enjoy multimedia simply by using the TV remote control through the SIMPLINK menu.
  1. Connect the SIMPLINK HDMI Output port to the TV HDMI Input port with an HDMI cable.
  2. GeneralSIMPLINK.
  3. Configure the SIMPLINK settings.
  4. Exit the SIMPLINK settings page.
  5. Turn on the connected device. The device is automatically connected to the TV.
  6. If the device is not automatically connected to the TV, click the Input button.
 

Willo3092

VIP Member
Forum Supporter
How to use SIMPLINK



You can conveniently control and use various multimedia devices connected through HDMI with the TV remote control.


1. Connect the SIMPLINK HDMI Output port to the TV HDMI IN port with an HDMI cable.
2. Press the
button on the remote control and select
at the top right.

3. Go to
► General and select SIMPLINK




4. Set SIMPLINK to On.



5. Configure the Auto Power Sync settings to On or Off. (If Auto Power Sync is set to On, turning on a SIMPLINK-linked device will turn the TV on.

When you turn off the TV, the device will also be turned off.)



6. Turn on the connected device. When the TV automatically connects to the device, the input will change.

If the device is not automatically connected to the TV, click the Input button.


● This feature works only with devices with the
logo. Check for the SIMPLINK logo on the external device.

There may be a problem using the device if the device does not meet the required specifications.


● A high-speed HDMIⓇ cable with CEC (Consumer Electronics Control) function is required to use SIMPLINK.

Pin 13 of the high-speed HDMIⓇ cable is used for data transfer between devices.


● If you want to output sound to the external audio equipment connected through the HDMI cable, set SIMPLINK to On.
 

dt99

TK Veteran
Thanks, I should have said, already tried that and it seems to make no difference. Maybe it's just the way the LG TV works, it's just annoying having to keep switching inputs every time.

I have sent an e-mail to LG to ask the question in the hope that there is a hidden option somewhere.
 
Last edited:

dt99

TK Veteran
In case it helps anyone else I got it sorted. You have you switch off the Program List Update option which is found in Program Tuning and Settings. The TV then remembers the last input used when it is switches off.

Why LG would put this under a real obscure option is anyones guess. @Willo3092 Thanks for your input and suggestions
 

Willo3092

VIP Member
Forum Supporter
I'll have to have a look at that when I get home from work, thanks for the update.
I've got an LG TV in the bedroom with a Formuler F1.
HDMI CEC never worked on any other receiver so never bothered trying with the Formuler.
 

Getrom29

Registered
I have a problem where when all devices are in standby TV soundbar and zgemma H9 if my zgemma is in standby before turning on TV my soundbar doesntvcome on automatically like it did before I connected the zgemma to my TV.

If I turn on zgemma before turning on TV then soundbar will come on with TV at same time how do I fix this
 
Top