Mag box 250 won't power up

mozzy1

Newbie
My Mag box 250 won't power up,i have tried a power adaptor from another box which is working fine. has anybody got any idea what it could be or is there any fixes...thank you in advance.
 
Last edited:

linesman66

TK Veteran
TK Supporter
My Mag box 250 won't power up,i have tried a power adaptor from another box which is working fine. has anybody got any idea what it could be or is there any fixes...thank you in advance.
Try a openbox power adapter to see what
Happens

Sent from my SM-A520F using Tapatalk
 

mozzy1

Newbie
Thread starter
Hi Macca, I cant, the box wont power up. I've tried various power leads and its not an adaptor issue, thanks
 

mozzy1

Newbie
Thread starter
I suppose the problem is now, I have opened it up the check the power socket had not de-soldered, so I've messed up my warranty ...unbeknown to me the guarantee
was 2 yrs :mad:
 

linesman66

TK Veteran
TK Supporter
I suppose the problem is now, I have opened it up the check the power socket had not de-soldered, so I've messed up my warranty ...unbeknown to me the guarantee
was 2 yrs :mad:
Once you break the seal. Your warranty is
Void

Sent from my SM-A520F using Tapatalk
 

macca40

Member
I suppose the problem is now, I have opened it up the check the power socket had not de-soldered, so I've messed up my warranty ...unbeknown to me the guarantee
was 2 yrs :mad:
Buy yourself a new Mag 256 and bin the 250 make sure you buy a genuine Imfomir box.
 

nicoj24

TK Veteran
Get yourself a new 322 much faster and better than the very old mag 250 which is no longer produced nor the mag 256
 

Mr Hanky

Newbie
Unplug it then plug it in while pressing the setup button constantly for a minute, if you don't get a blue screen. Its trash.
 
Top