PIA vpn on octagon sf8008 setup

satfoot

Newbie
I will appreciate some help please on setting up PIA vpn on octagon sf8008 running on openatv_6.4 (or any other image, as I have more in multiboot).
All I have is PIA account username and password. Thanks.
 

pabloescaban

VIP Member
TK Supporter
Can confirm that conf importer works fine.
Just input user and pass and choose pia from providers.
After saving and reboot you open vpn manager plugin and choose a country to connect to.
Try for EU countries, not Argentina or Brazil etc
 

satfoot

Newbie
Thread starter
Thanks for your help. I think I got it running. But how do I check to be sure? In Network/Adapter Settings Primary DNS has changed.
 

satfoot

Newbie
Thread starter
Thank you all. What seemed difficult at first became extremely easy. Finally a big thank you to lamblamb.
 

AJP007

Newbie
Just a quick update about my PIA VPN signing with Lamblamb this evening.
Really great offer thanks again Lamblamb.

My very first attempt at VPN seemed to work well..!

Octagon SF8008 Twin 4K - OpenATV 6.3
Installed via IPK installer
1. IP Checker
2.VPN Conf Importer and this installed the VPN Manager ALL in the plugin Folder.
RE-BOOT Box.

Thanks to the excellent posts here I am up and running after a few teething problems with a couple of "Login Error AUTH_Failed" messages.
I think the first problem was the File with my username/password which I first named "vpn/txt" and put into Tmp Folder. This was NOT correct.
This gave me two Blue Screens.

Then I renamed the file to "vpn.conf" with my Username/Password enclosed and put it into /media/hdd/ alongside a created File called "grogspiavpn".

Back to "VPN Conf Importer"
Import Credentials = Yes
Username: xxxxxxxxxxxx
Password: xxxxxxxxxxxx
VPN Provider PIA
Finish and Exit by pressing Blue Button bottom right "SAVE"


Then into VPN Manager...Press Menu - Top lIne - Select All Config in one Folder = Yes
leave everythng else as is...Exit with OK

Back to Screen with the Country choices and Select one.

Top right corner you will see the Globe with VPN Lock change colour from RED to GREEN
Then check with IP Checker if the IP has changed and your up and running.

That was it hope this little How to..........helps others.
Cheers
AJP

I have a few Q's for our experts:-
Do I Shut down VPN or is alright to leave ON when shutting Box down.?
In "VPN Manager" should the OpenVPN Autostart be crossed RED?
Is it normal for the chosen Country Server to shut down on its own?

By the way where is the Lamblamb PIA VPN Thread gone?
Where can I find the VPN Speed plugin?
Thanks Guys
 

urie

TK Veteran
TK Supporter
@AJP007 the file is you put in tmp is called vpn.txt also for future installs if you ftp to etc\openvpn folder there is file called pass.file copy that to where your openvpn config files are stored i.e, in your case grogspiavpn you can rename the folder as long as you set vpnmanager to its path.

So now if you ever need to do clean installation of vpn manager your username and password details are stored on your hard drive, or if you are testing vpn's to find one that suits this way you can just point vpn manager to what ever vpn supplier config file set you want.

Lamblamb PIA VPN thread may have been deleted it was only posted for the offer it is not a support thread.
as for speed test plugin go to menu>plugins>download plugins>extenstions>e2speedtest(0.005) and install in.
 
Last edited:

AJP007

Newbie
@ urie,
Thanks for the Info super, live and learn is my motto,

I am using the Multiboot Octagon 8008 with openATV 6.3 and it seems that the VPN Config Changer has ALSO installed itself onto another of my images
the openPli 8 on Slot 2, which does NOT support VPN at present. Can I get rid of it via Remove Plugin option?

Another Q please, do I need to shut down/disconnect the VPN Connection when I shut down the Box, or can it stay Connected.?

Last Q why does activating the VPN dissconnect my oscam connection?

regards.AJP
 
Last edited:

rapidwrinkly

Member
TK Supporter
I don't have it anymore on my box but yes you can just turn box off, pretty sure you can tick a box to autostart when turning back on.
 

dsayers2014

VIP Member
I am using the Multiboot Octagon 8008 with openATV 6.3 and it seems that the VPN Config Changer has ALSO installed itself onto another of my images
the openPli 8 on Slot 2, which does NOT support VPN at present. Can I get rid of it via Remove Plugin option?
Yes you can remove VPN Conf Importer


Last Q why does activating the VPN dissconnect my oscam connection?
The box reconfigures the network just restart oscam if needed.

It could be that the line doesn't like VPN been used so ask your provider if VPN is ok to be used if it won't start with vpn.
 

AJP007

Newbie
@ David, thanks for replying,

VPN Conf Importer will NOT uninstall on this openPli 8, tried several times using the "Remove Plugin" option and Full Restart..but its NOT going away.
Maybe its Embedded in the Image, will check with the Makers

Network reconfiguration is something I did NOT think of, Tried to Run Network Test and both last options IP Address and Namserver remained RED
All other options were GREEN will wait a little longer next time. Also tried "Restart softcam", maybe I;m just too impatient on both counts.

Yes..I checked with my Providers before signing up with Lamblamb for his superb offer, so in that respect I'm OK
both said VPN no problem whatsoever.


Just looking for a decent IPTV provider - but thats another issue.
Thanks - regards AJP
 

AJP007

Newbie
Having a few problems with VPN again today, keep getting LogIn error
here are a few Screenshots of my Configuration.
The "vpn.txt" File was placed in TMP.
See Pic's of DCC_E2 with the "pass.file" where also the "grogspiavpn" File is in Media/HDD/
The VPN Conf Importer was checked and "Import Credentials - Yes" then End with Blue Button "Save".
Then on to VPN Manager and choose country, the Globe in right hand side Corner Spins and then I get the "Login Error Auth Failed" message.
Are my Menu VPN MAnager settings correct ?
see attachments below

Any advice please..dont understand, ran well until this evening.
Thanks regards.Andrew
 

Attachments

  • PIA VPN Manager 01.jpg
    PIA VPN Manager 01.jpg
    269.4 KB · Views: 5
  • PIA VPN Conf Importer 02.jpg
    PIA VPN Conf Importer 02.jpg
    213.7 KB · Views: 5
  • PIA VPN LogIn Error.jpg
    PIA VPN LogIn Error.jpg
    370.3 KB · Views: 5
  • pass.file in media_HDD.png
    pass.file in media_HDD.png
    36.2 KB · Views: 4
  • vpn.txt File in TMP.png
    vpn.txt File in TMP.png
    40.9 KB · Views: 4
  • Menu VPN Manager Settings.jpg
    Menu VPN Manager Settings.jpg
    156.5 KB · Views: 4
Last edited:

urie

TK Veteran
TK Supporter
Having a few problems with VPN again today, keep getting LogIn error
here are a few Screenshots of my Configuration.
The "vpn.txt" File was placed in TMP.
See Pic of DCC E2 with the Filesc in Media/HDD/ and then the VPN Conf Importer was Checked "Import Credentials - Yes" then End with Blue Button "Save".
Then on to VPN Manager and choose country, the Globe in right hand side Corner Spins and then I get the Login Error Message
see attachments below

Any advice please..dont understand run well until this evening.
Thanks regards.Andrew
have you tried a different server also check the contents of the pass.file that username and password is correct if it is copy pass.file to Harddisk\grogspiavpn folder.
 

AJP007

Newbie
@urie, thanks for your reply,
YES tried a different server in fact a dozen since 7pm this evening, OK I will put the "pass.file" DIRECTLY INSIDE the grogspiavpn Folder and re-boot Box.
user and pass are correct will check one more time.
regards
 

Attachments

  • DCC_E2 Pass.file in media_HDD_grospiavpn_folder.png
    DCC_E2 Pass.file in media_HDD_grospiavpn_folder.png
    51.8 KB · Views: 3
Last edited:

AJP007

Newbie
NO luck still gettig "Login Error Auth Failed" maybe Lamblamb has an idea, have to wait till he reads this.
Silly question in the "pass.file" do I insert
Username: xxxxxxxxxxx
password: xxxxxxxxxxx
or just the
xxxxxxxxxxx
xxxxxxxxxxx
regards.Andrew
 

urie

TK Veteran
TK Supporter
NO luck still gettig "Login Error Auth Failed" maybe Lamblamb has an idea, have to wait till he reads this.
Silly question in the "pass.file" do I insert
Username: xxxxxxxxxxx
password: xxxxxxxxxxx
or just the
xxxxxxxxxxx
xxxxxxxxxxx
regards.Andrew
just
xxxxxxxxxxx
xxxxxxxxxxx

you can also get the pass.file from etc\openvpn folder that is where vpn manager it saves your last login open vpn files if you had for example nord and pia openvpn config files in seperate folders on hard drive with the pass.file in each vpn provider folder.
 
Last edited:

AJP007

Newbie
just
xxxxxxxxxxx
xxxxxxxxxxx

you can also get the pass.file from etc\openvpn folder that is where vpn manager it saves your last login open vpn files if you had for example nord and pia openvpn config files in seperate folders on hard drive with the pass.file in each vpn provider folder.
You are a GOD send urie, that was it, the pass.file was incorrect WITH username: xxxxxxxxx and Password: xxxxxxxxxx
Thank you very much for your Help and Support in getting this sorted.
I am mind boggled how this happened, HAVE no idea..BUT, OK its sorted thanks to you. UP and running again.
Just checked the openVPN folder where the pass.file sits and YES it is correct there.!!
regards.Andrew
 
Top