HD51 4K Picture Pixalating?

jazz

Registered
I have a problem with my Mutant HD51, the picture keeps glitching and pixalating, this happens every few minutes and lasts for a second or two. This is happening on the freesat channels. I have checked the signal strength on the receiver which seems to be low, SNR 73%, AGC 55%, BER 0. Would these figures cause this problem?
 

cactikid

VIP Member
Forum Supporter
Thinking cable or f connectors need rechecking as i get that on 19.2 and have a faulty cable.
 

jazz

Registered
Thinking cable or f connectors need rechecking as i get that on 19.2 and have a faulty cable.
I hope to check out the cables and connectors tomorrow. Did you solve your problem on 19.2 with a new cable or connector?
 

grahamer67

TK Veteran
Forum Supporter
Been having a bit of pixelating earlier on premier sports while football was on, now once its over, it seems to have settled down again, it was happening quite a bit last week on BT sports, again while football was on, has anyone else had similar?
 

moshibeth

TK Veteran
Been having a bit of pixelating earlier on premier sports while football was on, now once its over, it seems to have settled down again, it was happening quite a bit last week on BT sports, again while football was on, has anyone else had similar?
A lot having issues with bt on cable and as most still seem to have a dish available. I for the life of me cannot see why not have a sat sub as an extra option as still a fair amount on it.
 

jazz

Registered
The problem I have is with the free channels on satellite, so I guess it's not a premium channel problem.
 

grahamer67

TK Veteran
Forum Supporter
A lot having issues with bt on cable and as most still seem to have a dish available. I for the life of me cannot see why not have a sat sub as an extra option as still a fair amount on it.
Yeah I still have sat and I ended up just using it last weekend for BT sports instead of cable, the point I was trying to make though was over the last few weeks, while football has been on BT HD or Premium Sports HD , there has been quite a bit of pixellation, and once the football is over the picture goes back to being ok, its just that its a strange one to figure out.
 

moshibeth

TK Veteran
Yeah I still have sat and I ended up just using it last weekend for BT sports instead of cable, the point I was trying to make though was over the last few weeks, while football has been on BT HD or Premium Sports HD , there has been quite a bit of pixellation, and once the football is over the picture goes back to being ok, its just that its a strange one to figure out.
Only on cashe servers
 

cactikid

VIP Member
Forum Supporter
I hope to check out the cables and connectors tomorrow. Did you solve your problem on 19.2 with a new cable or connector?
No i have to get an installer out as its on my motorised supply and tonight it was crap,floorboards need to be taken up and new feeds added + saorview aerial connection.
 

jazz

Registered
Thanks. I have managed to check all of the connections and cables, all are fine. I also connected the receiver to another satellite dish and it's the same problem, also connected an old zgemma to the satellite feed which displayed excellent SNR & AGC readings with no pixalisation, so I guess there is a fault with the Mutant receiver?
 

grahamer67

TK Veteran
Forum Supporter
Only on cashe servers
I am Not on a cache server, but I replaced my 3 year old Labgear splitters with new Labgear ones today and the problems fixed, so it seems for me the splitters must have been done
 
Top