Starview 2 The Box in Dublin

Evastar

TK Veteran
A friend of mine has one of these and she lost all her channels about three weeks ago, she is n*l Dublin, if i update it with the latest firmware will she have all the channels except movies, sports etc?

And could you remind me what is the latest firmware for The Box please?
 

anto1969

Super Moderator
Staff member
Forum Supporter
eva at xmas I put FW. 4.55 on one of these for my brother and its fine :)

Its a rar type file and the 4.o3 loader is in it, you'll get it in link mooley putup :)
 
Last edited:

Mooley

TK Veteran
Yeah thats where I sent you the link from Eva!!

Actually sorry I sent you the link from the starview sticky! Pretty positive it's the same rar file though. Same version and dates.
 
Last edited:

Evastar

TK Veteran
Thanks, i had the stuff on my pc and deleted it a couple of weeks ago, thought i wouldn't need it anymore! LOL
 

everestin

Registered
thanks, i have tried this but my own sv2 will not allow a down load of any firmware it says its down loading but the progress bar never moves and it remaains at zero percent, and the lights dont even flash. Any ideas i have no doubt that others are having sucsess.

Am stuck on the language set up page and forget how to escape
 

moh

Deleted, at user's request.
You have to choose English > Installation > Automatic Scan > it should say 176 channels found .
Exit , Then press menu 1570 > Turn the EMU key ON




taken from elsewhere:
 

everestin

Registered
thrnks again. the % bar on the loader wont move. it does not want to move at all and remains at zero. will keep trying. i hav e tried with the box on and off standby and full on but no life . i did put in firmware for starview one into this box and i think thats what is still in it but the reason i did that was it would not take a flash of the s"2 firmware that was available in march. it took the flash for the starview one.so thats whats in it. looking at the discrypions by photo i think its a s"2 but it wont take any of that firmware by my hands anyway.was exited when i read taht the flashing of the latest firmware was working for others in dublin
 

cactikid

VIP Member
identify box first then firmware,xp or vista and pc,and most important null modem cable,and selecting correct com port.
 

noelyf

VIP Member
Menu > system info > press ok & post what it says please everest.

And have a read of cactis post above ;)
 

moh

Deleted, at user's request.
Menu > system info > press ok & post what it says please everest.

And have a read of cactis post above ;)
Glad someone in the know how came along i was struggling plus sweating there LOL
 
Top