[TUT] Streaming Media from a PC > Zgemma

Burlesy

TK Veteran
I DO NOT TAKE ANY RESPONSIBILITY FOR ANYBODY WHO BRAKES THEIR BOXES/PC'S - PERFORM AT YOUR OWN RISK :)

Streaming Media from your PC to your Zgemma (enigma2 box)

In case anyone is interested - here is a guide I created on how to stream media from a standard PC to your enigma2 box. I see people have touched on the topic using a NAS but not using a PC.
This tutorial has been produced using windows 10 & with a zgemma h2h

Scenario
Let’s say you have a collection of Movies/Music/TV Series on your PC hard drive.
Dragging them over to the Zgemma USB storage device is annoying right – as is searching IPTV player for TV Series to find out ‘No links available’ ITS TIME CONSUMING!

Requirements
Laptop/PC
Zgemma – on the same network as the Laptop/PC

Instructions

1) Start > Control Panel > Network and Sharing Center > Change advanced sharing settings.
  • Turn on network discovery
✓ Turn on automatic setup of network connected devices.

  • Turn on file and printing sharing
  • Use user accounts and passwords to connect to other computers.

Media to Zgem.jpg


Turn on Media Streaming - Google it Or windows 10 users: Control Panel\All Control Panel Items\Network and Sharing Center\Media streaming options

Let’s go ahead and sort out the folder to share.
I have put all my media in 1 folder to make it easier.

2) Get all your media folders (TV, films & music) and put them into one folder.
Example:
  • Media
    • Films
    • Music
    • TV
Media to Zgem - My folders.jpg

Once you have done that right click the folder which contains all the media (in my case the "Media" folder)
Right Click
Properties
*Folder Properties window will appear*
Sharing Tab
Advanced Sharing
Tick “Share This Folder”
*Enter share name* (Make note of this)
Optional – Click Permissions and set the permissions to Read only
Apply > ok
Close
Media to Zgem - shareing.jpg
Next find out the name of the computer.
Windows 10 > Start > Settings > System > About > PC name: *make note of that*

Now to configure settings on the Zgemma

3) Menu > Setup > System > Network > Mounts setup > Mounts Manager

Add new network mount point
Mount Using: FSTAB (mount at boot)
Active: enabled
Local share name: *Insert share name of the folder we setup in the previous step*
Mount type: CIFS share
Server IP: *Insert IP of the PC/Laptop *
Server Share: *Insert name of PC*
Use as HDD replacement: no
Mount options: “ro” (read only)
Username: Username you use to log into the PC
Password: Password you use to log into the PC
Click Ok then Yes to Save
Media to Zgem - mount settings.jpg
Menu > Setup > System > Network > Mounts setup > Mounts Manager > Mountpoints Management
If you have done it correctly it should look like this:
Media to Zgem - After.jpg
there should be no 'X' next to the highlighted icon.

Restart the box.
File List > net
Sometimes your system defaults to the location where your recordings are stored. You want to navigate to this directory: root/media/net/

Enjoy!

Feel I missed anything? PM me
 
Last edited:

Taffdan

Registered
Hi mate, trying to do this but can't get past the red x on the mount. Everything else is as it should be
 

Burlesy

TK Veteran
Double check that the folder name you shared is correct (including the Caps).

The PC with the media you're trying to stream is on the same network & is switched on?
Also is the PC's OS win10?
If you set up the win10 user with the email address, then the username will have to be the email address.
 

jia1000

Registered
Great tutorial Burlesy, simple and easy to follow. However I have encountered a problem. When I press FILE LIST button I don't see net?

I have a green tick in the box under network mounts manager.

Any ideas?

Thanks

Sent from my Vodafone Smart ultra 6 using Tapatalk
 

Burlesy

TK Veteran
yeah sure,
when you file list what do you see?

You want to navigate to the /media/ folder.
in that folder you should see
net
hdd
autofs
 

jia1000

Registered
All I see is my recordings when I press FILE LIST, no net.

But I can access it another way by going into plugins> dream xplorer> media> net.

Is there a way to add that folder to where my recordings are? Easier for the Mrs! Lol

Sent from my Vodafone Smart ultra 6 using Tapatalk
 

Burlesy

TK Veteran
Lol cant she just click yellow(location) go to internal flash/media/net

Sent from my E5823 using Tapatalk
 

jia1000

Registered
She's gonna have to unless I pick up the remote and do it for her! Lol

Thanks for helping

Sent from my Vodafone Smart ultra 6 using Tapatalk
 

Burlesy

TK Veteran
No worries,

I think I'm going to have to simplify it even more at learn how to add the directory to the bouquets :)
 

jia1000

Registered
Just one other question: what is the name of your PC? Is it "Media"?

Sent from my Vodafone Smart ultra 6 using Tapatalk
 

neaf

Registered
I'm lost

Hi . can anyone help on this subject.iv' managed to follow the tutorial and it recognises my folder but when I open the folder it's blank as if it is nothing in there. When I now there was a album in there.
The folder appears in media/autofs/

Thanks in advance
neaf
 
Last edited:

Burlesy

TK Veteran
Go to mount viewer and see if there is a a red X next to the icon highlighted if there is then something is wrong.
It should be in root/media/net not media/autofs.
have you enabled media sharing on the pc?
 

neaf

Registered
Hi . yeah iv' got the tick not x ...I have noticed the folder you mentioned but it got some file in it that does nout. ..I will check tonight and update . yes iv' enabled share on my laptop. .Thanks for replying.
 

neaf

Registered
Hi.i checked my settings last night re-applied a new folder but same outcome.
Autos
hdd
Memory card
Net> media>f'stab.

My folder is media after media it should show my music...so i googled fstab and seems to be pointing to mounting issues
 

Eejit

Registered
I have struggled for several days to get this to work and finally came up with this-


On the my Zgemma H.2S I have gone into the Mount Manager and "Add a new mount point" with following settings:


Mount Using: FSTAB
Active: enable
Local name: Movies - (This can be anything)
Mount Type: CIFS share
Server IP address: 192.168.1.6
Server share: /Movies - (Movies is the share name of my folder that is in the root)
Use as replacement HDD: no
Mount option: rw
Username: server
Password: password


I also have two other mounts which are identical except for below:
Local name: TV
Server share: /TV


Local name: Music
Server share: /Music


My PC hard drive set up


/
- Movies
- Music
- TV


Hope this helps
 
Top