1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hi Guest, If you haven't already please like our Facebook Page. We post Discount Codes for the Major online retailers. We saved members a fortune over Xmas and continue to post amazing discounts for everyday items. You need to add us to see what i'm taking about. CLICK HERE - click LIKE, add us to "SEE FIRST". So you don't miss expiring codes.

Bad reception

Discussion in 'General Satellite Discussion' started by tonycrowuk, Dec 17, 2016.

  1. tonycrowuk

    tonycrowuk Registered

    41
    0
    6
    Hi guys had my zgemma box now for over 2 years been great. However now 50% of the channels pixealte really bad.

    I have bought a new lnb new sky ends but no joy. BT sports the one I miss most of all your help would be greatly appreciated thanks in advance
     
  2. wheelo

    wheelo Admin Staff Member

    13,121
    1,515
    175
    {bus driver
    Dublin
    One thing I would try is to get a test line, and rule that out. I mean the only other thing would be if the dish were corroded beyond repair, teh box itself, or your HDMI cables - off the top of my head
     
  3. cactikid

    cactikid VIP Member

    16,568
    1,256
    133
    you only replaced the lnb but what is your sat cable quality like?
     
  4. Pale-Rider

    Pale-Rider Registered

    100
    0
    0
    If you only replaced the LNB your dish could be misaligned or the cable split / corroded etc. Check the dish first then trace the entire length of the coax (as much as you can), look for any splits or wear to the coax and if you find any rip the lot out and replace it. Also remove and refit ALL the F-plugs at the LNB and receivers end and make them good.
     
  5. mrtweaks

    mrtweaks Registered

    387
    15
    18
    {Being ill
    midlands
    You only need one single tiny wire to short and it will stop you watching. My son had the same problem and I did a short/continuity check and found one of the leads had a short refitted the f-connector and great picture now.