1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB device becoming read only on Wooshbuild 4 / OpenATV?

Discussion in 'Zgemma-star 2S' started by RustyMG, Dec 27, 2016.

  1. RustyMG

    RustyMG TK Veteran

    960
    224
    Hi all,
    Seen the following problem a few years ago on some Enigma boxes but nothing lately on the 2s / H2s.
    The inlaws 2S stopped populating the EPG the other day, and when I attempted to start a download manually, I got a "cannot open crossepg database" error.
    I attempted to remount the 64gb usb stick in the same (rear) socket but even after it "took" and the system reset as it requested, when I went back in there was no device listed, and I had the same problem when using the same USB stick but time in the front port - where it actually crashed the box twice.
    So, I thought, ok if the USB stick has somehow become read only, I'll just try another stick.......and the 2nd stick, that I know is perfectly fine, gave the exact same problems.

    Is there something simple I can try that Im forgetting before the usual last resort of a reflash?

    PS

    Merry Christmas everyone!
     
  2. dsayers2014

    dsayers2014 TK Veteran

    9,789
    1,193
    You can try to format xt4 on pc first then all you should need to do is check mount
     
  3. Buckham_uk

    Buckham_uk TK Veteran

    534
    22
    Mine has done something similar in last couple weeks but I believe it's just the USB that's died. Haven't bothered to use another yet with being uber busy but hoping it's just a case of a dead USB as the led indicator no longer works when it's plugged in

    ---------- Post Merged at 03:06 AM ----------

    Will try the format first and give it another pop just in case
     
  4. Ad29434

    Ad29434 Registered

    427
    63
    I had this with my H2S a few weeks ago i had a 64gb Kingston which was only 2 months old.one night it just became read only.i tried every thing i could find to reformat it on PC but nothing worked at all. now its useless.
     
  5. RustyMG

    RustyMG TK Veteran

    960
    224
    As mentioned guys, I initially thought it was just a duff usb stick, but I used another stick that I know 100% was fine, and that too gave the same errors. In both usb ports.....
     
  6. Clark9t

    Clark9t Registered

    16
    0
    Hello firstly sorry to hijack and drag an older thread up but I've had my zgemmah2s box approx 3 weeks purchased with gift. It's been brilliant but I noticed my epg had changed wasn't fully populated the other day and also I couldn't record to what is a 32gb USB stick! Epg had been fine and I could record until now.

    Memory has changed to internal and cannot be modified. USB stick is in a read only state and I have tried a number of programs to format back to FAT32 to reinitialise it but nothing works.

    I cannot mount or I mount on the box whilst the USB is plugged in either.


    Curious if you found a solution?
     
  7. RustyMG

    RustyMG TK Veteran

    960
    224
    Hi, nope never found a fix.
    In all the 2S's and H2s's Ive set up, this was the only box it had happened on.
    Never found a fix, so just reduced their EPG to 3 days so it wouldnt fill the internal memory, as they never record on the box or used timeslip.
    Might update wooshbuild 4 to v5 for them to see if it fixes it, but the 2S is slow enough with v4, so torn.........