Can't connect to NAS in iptv portal with 322

Hi,

We had a Mag 254 which worked great but eventually gave up so we replaced it with a 322. All is good with this except one problem which is driving me potty. For some reason we can no longer access our NAS to play our media files in the iptv portal under the 'Media Browser' folder. This worked just fine with the 254 but nothing appears here and I can't see a way to map the NAS address manually.

In the Media browser if I click UPnP then I get an empty folder. If I click LAN there's nothing there. However, if I go into the inner portal in the 'Home Media' section and click UPnP I can see the NAS and browse to it. I can also map folders from the top level directory. The files play just fine through either of these methods. The only thing I can't do is get anywhere by browsing to the 'Network' option as then it says 'Unable to get working group list'.

Is there a way to map the folders directly in the iptv portal like there is in the inner portal? I've fiddled around with every single setting I can find in hope it would resolve it but it's got me stumped. Maybe I've missed one and someone knows how I can get to the files? I can't remember there being any issue when we got the 254 although that was a long time ago.

Thank you for any suggestions.
 
Top