Citroen Dispatch electrical problem.

ruston

Newbie
Hi there, I have recently purchased a 2006 Citroen Dispatch van fitted with the 2.0 hdi engine and have (to me anyway!) a strange problem. The chap I bought it off, a mate as it happens, said that a few days before I had it the ignition warning light came on faintly while driving but a garage had checked it over and it was still charging. However the warning light doesn't illuminate when I turn the ignition on but does light when the engine is running! It appears to be charging, the headlights brighten when I raise the rpm and a meter across the battery shows 14.75 volts but I'm not happy using the vehicle like this. The electric windows wont operate either until the warning light actually comes on, pretty sure they should work with the key in the 'accessory' position like my Peugeot Partner but I don't know if this is anything to do with the main problem? Any advice welcomed, I was a mechanic in a different age but not an auto electrician and suspect the alternator but am loathe to fit one incase the problem persists. Thanks for reading this rather long winded first post but I will be greatfull for any feedback.

Pete.
 

cactikid

VIP Member
ignition,oil,handbrake and other lights should come on with ignition on,wonder if diodes are going in altenator and might be on its last legs,can you check all connections are good to altenator and battery grounds are good.
when you mention electric windows not working also tend me to think of other issues bsi?

https://www.youtube.com/watch?v=uIZj96PFuRU
 

ruston

Newbie
Thread starter
Thank you for replying. All the other warning lights appear to function normally, though at one time the AIR BAG warning stayed on for a few minutes but that hasn't happened since. I will check all the connections, it looks like the original alternator which is 10 years old and 123000 miles so am prepared to replace it but just wanted to get a second opinion really. The window issue isn't really a problem to me as a driver, but the wife would like to be able to operate the passenger window when we are parked up with the engine off so I might persue sorting that when I get the alternator side working.
It just seemed strange that the alternator light was lighting when the engine is running but not working with just the ignition on, something I haven't encountered before but you live and learn daily! I was told that you can just replace the diode pack but I think an exchange unit is the better option.

Pete.
 

ruston

Newbie
Thread starter
Thank's Hornet, time to bite the bullet and get my wallet out! I will put one on.....when it warms up a touch as I'm not using the van at the moment!(y)

Pete.
 

cactikid

VIP Member
you may have 2 choices a new unit or refurbish your own and 12 months warranty.check local area for starter and altenator, auto electrical supplies in yellow pages or google?
 

ruston

Newbie
Thread starter
I have priced an exchange unit at £110 plus vat so will probably go for that. I have an account at the factors so get discount. It is still charging at a constant 14.44 volts but I guess that it will fail eventually.
 

ruston

Newbie
Thread starter
Well, I replaced the alternator today with an exchange unit, turned the ignition on and the blooming light still doesn't work! I can't try it for charging yet as I am waiting for a new belt tensioner but I assume that like the old unit it will charge OK. If the bulb has failed then surely it wouldn't light (admittedly dimly) when the engine is running? I reckon a visit to an auto electrician is the next step, once I get the belt back on. On the plus side the old unit had rough bearings, plus the belt tensioner pulley bearings were rattly so at least something positive has come from it!

Pete.
 
Top