Delphi DS150e not reading Mercedes cars

Snapper93

TK Veteran
When using Delphi with Autocom CDP+ I get message stating that vehicle not responding when trying to read Mercedes cars. Works fine on other makes but sometimes won't show description of fault code - just the code when using diagnostic option - but code and description on eOBD.

The version 2014.2 . Tried a full reinstall but still no luck on Mercs. Have read on interweb that sometimes diodes need swapped on the board.

Anyone any ideas or advice if they have had similar issues - or even a link to newer version of software by any chance?

Cheers
 
Sponsored Links

BeakyFord

TK Veteran
I haven't used this software for a while but recall its doesn't cover some mercs or BM's. there is other software for these but again its been so long I dont recall which, maybe someone else can shed some light on this for you
 
Last edited:

cactikid

VIP Member
Forum Supporter
With many diagnostic tools one might have to check your entering correct info to allow scanning as some may not connect?
 

Snapper93

TK Veteran
Thanks guys - strange thing is that it used to read Mercs and BM's and just stopped all of a sudden. So tried a reinstall and it reads BMW again, but not Merc.

Cactikid - when you say correct info - do you mean correct car details or the settings in com port or something else altogether mate?

Wonder if Wurth Wow works with Autocom?
 

BeakyFord

TK Veteran
yeah wow works with it as have/had both software's on a tablet I used but you don't get anything different from it, where ever you got the system from will probably have sent you a text doc or it was on the CD, that's where I recall it seeing some merc's/bm's are not covered. I lent mine out to a friend for a few days to check an Audi with VagCom, come to think of it that was months ago & I've still not got it back....typical!
 

cactikid

VIP Member
Forum Supporter
https://www.ebay.ie/itm/253734159177
I ended up having to buy this bit of kit as our Brain Bee is too old,Launch having issues [ not mine ] and auto boss behind the times.
The Autel one asks me more questions like having a special gearbox and other things as all you know is year of car and model make but sometimes we choose the wrong path.
Autoboss would ask what version model type 124 and scan under that having checked the sticker on door frame.
Not used tablets or laptops but same port would be used for all diagnostics.
My Autoboss got corrupted and lost loads of data hence the new upgrade rather than buy another dear subscription.
 

serano rakino

Registered
I haven't used this software for a while but recall its doesn't cover some mercs or BM's. there is other software for these but again its been so longRedtube Beeg Spankbang I dont recall which, maybe someone else can shed some light on this for you
yeah wow works with it as have/had both software's on a tablet I used but you don't get anything different from it, where ever you got the system from will probably have sent you a text doc or it was on the CD, that's where I recall it seeing some merc's/bm's are not covered. I lent mine out to a friend for a few days to check an Audi with VagCom, come to think of it that was months ago & I've still not got it back....typical!
 
Last edited:
Top