Techkings

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

No power on box

Peopeers

Registered
After downloading the latest openatv for my zgemma H5.2tc and also flashing latest WooshBuild Infinity all was working fine and my virgin line was working woke up the next day and the box has died no power no stand by have also tried a few different power leads but still nothing from the box any ideas it’s these than 12 months old
 

maxal

Registered
I am an ex re seller of Zgemma boxes and it is very rare for a Zgemma box to fail but I had one box out of all the boxes I sold fail that needed replacing, it had the same symptoms that you are describing.
 

Peopeers

Registered
Hi thanks for reply’s any ideas where I might pick something up today that would power the box up like Argos Screwfix B&Q had a look on Screwfix can’t seem to find anything similar
 

Willo3092

VIP Member
Forum Supporter
No one actually sells genuine PSU's for E2 boxes now though afaik.
The manufacturers are supplying 3rd party Chinese PSU's with new boxes.
Even my new Vu+ came with an unbranded PSU.
 

Peopeers

Registered
Mine wasn’t a psu it was just a plug in the wall with a ac/dc adaptor bought the zgemma from mobi-shop December last year
 

cactikid

VIP Member
No one actually sells genuine PSU's for E2 boxes now though afaik.
The manufacturers are supplying 3rd party Chinese PSU's with new boxes.
Even my new Vu+ came with an unbranded PSU.

Now thats a surprise knowing how bad chinese goods can be.
 

Peopeers

Registered
Have tried 5 different ac /dc plugs around my house including a laptop one an still no joy with getting any power
 

maxal

Registered
My mate had his box for 6 months before his developed the same fault that you appear to have.
 
Last edited by a moderator:

Peopeers

Registered
Have opened the box up was curious it might have had a 1amp fuse that may have blown also bought the box off mobi-shop through PayPal an I’ve paid someone totally different
 

Peopeers

Registered
Just ordered new h5.2tc my pen usb drive that was in the back off the box that’s dead would all my settings be saved on this? I backed them up before flashing latest atv and WooshBuild Infinity, and restored them am my box was working fine ? Or to I need to wipe everything off it an start again?
 
Top