Techkings

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Nvidia shield pro HDCP problems!

Toddy2

TK Veteran
Forum Supporter
Starting to get HDCP errors when watching Netflix and Prime video content!
I have a 4k 65 inch 7 series Samsung smart TV and when I use it with these apps I get the dreaded error message, the fix that lasts a day or two is to switch TV off at plug for a minute!
I have contacted Samsung via live chat and gone through all the settings etc but no change, my cables are hdmi 2.0 and 8k compliant!
I have followed all the Google info and Nvidia forums with no change!
I have read that some hdmi switches can strip the hdcp! But I'm guessing that could be at the expense of picture quality, Samsung's answer is to watch that content on the built in apps, but the quality of picture and speed of loading doesn't compare to watching on Shield! I have used all the hdmi sockets but same, unsure if it's a Shield software problem or Samsung compatibility, I do have a 4k TV in bedroom so may try that! Any one heard or have had a similar problem?
 

mike123

VIP Member
It is basicly your sheild is not communicating with your TV properly. best advice is try the sheild on another tv with a different HDMI cable. see what happens.
 

Toddy2

TK Veteran
Forum Supporter
It is basicly your sheild is not communicating with your TV properly. best advice is try the sheild on another tv with a different HDMI cable. see what happens.
Thanks for reply Mike! I get all that, I have now replaced all HDMI leads with premium certified ones, The only thing I haven't done is tried the other TV! But if it's all ok with another TV it's not really going to solve anything as it's used solely on my 65inch! I am not the only one with this problem! Don't know if it's just Pro software issue or if it's my TV having non compliant hdmi? Firestick works flawlessly using Netflix 4k content! I have everything mirrored as backup on stick! I may try factory reset but others have tried this with no luck! May have to just keep switching TV off at wall as fix for now which lets it play HDR and 4k UHD for the day which is odd!
 

Whitwori

Registered
I use the shield on my 8 Series Samsung and get no issues at all. Must be down to the software on Series 7?
 

Toddy2

TK Veteran
Forum Supporter
Some say try using a HDMI splitter that can sometimes resolve the issue.
I have been looking at that avenue! But apparently stripping the hdcp is deemed illegal! and some switches that did that last year won't this because if copyright issues!! So in theory you could be trying a lot of them before success! I have found info out on Shield site that adjusting CEC settings and dropping down lower than 4k 60khz can fix it !! I am now at 4k 50khz and it's still working!! Could have been a school boy error as the TV is 50 khz !!!!
Also the problem only came after the last big upgrade 802 *** I am keeping everything crossed at the moment, the shield is the dogs! But the customer service is a bit random, if you put in a ticket it takes 2 weeks to reply!
 

Toddy2

TK Veteran
Forum Supporter
I use the shield on my 8 Series Samsung and get no issues at all. Must be down to the software on Series 7?
Possibly so, but it was working flawlessly before the last upgrade, and upgrading the TV would be silly as it's less than a year old, it's something in settings!!
 

Toddy2

TK Veteran
Forum Supporter
Seems to be a issue with samsung TV's and the sheild and other devices for some reason.
There are a lot of questions regarding the problems with Sony and LG TVs as well on there site with the Shield Pro!! But not the pencil case model! I'm hoping my last tweak is the last tweak! Because if it works fine for 2 days then an error that clears after switching TV off at wall is a fix!! It can't be that much of a problem!
The next TV I buy will not be smart!!
 

mike123

VIP Member
Mine is a fairly cheap HIsense one got it from AO.COM got to say i have had no issues. I have got the sheild TV. however, i think the software is the same
 

Toddy2

TK Veteran
Forum Supporter
The last tweak didn't clear the issue!! Been in touch with scan.com seller and Nvidia Shield TV customer care, both mentioned factory reset of Samsung TV ! Which I have done with the purchase of another hdmi lead, Monoprice which was recommended on Nvidia forum and extremely cheap compared to others I have tried and genuinely premium certified £3.60.
I know people have said it doesn't happen on my TV! The problem did only occur with viewing Netflix and Prime video through there apps on the Shield! Since the reset and change of lead I have had two days of error free viewing, so hoping this was the fix! Samsung smart UHD TVs are a bit too smart! It's calling my shield a Roku after two edits to name!
 
Top