USB stick at fault for glitchy timeshift?

veronikkk

Newbie
Hi everyone, I have a question about timeshift. I personally rarely use it, but I got my folks set up with a Zgemma H2H running openATV and they can't do without this function, so they have "automatic timeshift" enabled. Anyway, I mounted a 128 GB 3.0 USB stick as HDD, and everything works quite well, recordings are always fine and even timeshift is okay for the most part, except for the fact that, from time to time, when in timeshift mode (or when watching a programme whilst it is still recording, for that matter), the playback either appears to freeze (hence, no audio either) for a few seconds before readjusting itself, or it just skips forward a couple of seconds.

The thing is that if I rewind when that happens, the playback at that exact same point is always smooth, which obviously means that the timeshift/recording is okay and no frames are actually dropped, but it's just the video playback that gets choppy for some reason. Don't get me wrong, that doesn't happen very often (I'd say once or twice in an hour), and I've noticed it only seems to affect HD channels that have a very high bit rate, and even those channels may be totally fine for several hours on end. Still, when it does happen, it is quite annoying.

Now, I'm no expert, but I can think of two logical reasons for this. Either the box gets overwhelmed at times when in timeshift mode (or, like I said, when watching an unfinished recording), therefore it's unable to properly handle simultaneous recording and playback, or the flash drive's speed is at fault here and, when faced with bitrate spikes while recording, it prevents the box from accessing the recorded file fast enough to have a smooth playback. What do you think, and is there anything I could try to fix this? I've already gone through a few things both in the timeshift and recordings menus, such as enabling a single or multiple buffer files, but I saw no improvements either way. I should also mention there is no swap file set up and have no idea if that would make a difference.
 

grog68

VIP Member
In the timeshift settings :

Turn 'Enable Autorecord' OFF
Set 'Automatically start time shift after' to 2 seconds
Then scroll down to Timeshift buffer limit (in hours) and set this to 5 or 6 at most
Set timeshift last events limit to about 4 or 5

When I first started using my own build I had the last to items set high, something like 12 and on my 1tb it wasn't an issue but then had people saying they had no space on their 64gb usb, when I took a look it was the timeshift that was filling the usb stick. This may be the issue you're having, it timeshift is filling the usb stick then it could be trying to free space up.
 

veronikkk

Newbie
Thread starter
Thanks for your answer, grog68. Autorecord is already disabled, timeshift actually starts after 1 minute (seems more reasonable to counteract their constant zapping between stations :)), buffer limit (1 hour), last events (1). The way they watch live tv, these settings are more than okay. Anyway, like I said, it's a 128 GB stick and I noticed this issue even when it had 90% free space. Besides, I've set it all up so they usually just stream or download already-aired programmes through a bunch of plugins, and they only record like one show a day, so the flash drive's free space is rarely below 70-80% and its main purpose is in fact timeshifting. And I've often monitored the situation through an ftp client after noticing this issue, and I'd say the buffer files in the timeshift folder are never more than a couple GBs in size.
 

veronikkk

Newbie
Thread starter
No, sorry, I should have made myself more clear. I mean, they just have a single timer set up to record a news programme once a day, that's it, as I've set it up so they stream everything off the Internet via plugins. Sometimes they do download some stuff, but what I meant was that the flash drive is in fact almost exclusively dedicated to timeshifting live tv and has plenty of free space available at all times. Anyway, like I said, this issue I described is definitely not a deal breaker, I stressed the box out for a few hours today and only noticed it once. Still, I was just curious what might cause this, the stick's speed or perhaps some plugin's process somehow interfering with the simultaneous writing/reading process and occasionally throwing the playback out of whack.
 

motahed

Newbie
Hi, I know this won't be much help but I also have had the exact same thing happen (PNY 128Gb USB) recently. Timeshift has always been perfect until the last couple of weeks (may be longer but I don't use my H2S very often) when I got the glitching you describe. I noticed another person asking about the same fault on these forums so I'm going to go out on a limb and say it's an OpenATV issue as that seems to be the common denominator. Of course it could be our sticks but they all seemed to work OK previously. :confused:
 

motahed

Newbie
Update: I have reflashed my box from scratch to Woosh V7 (basebuild from USB). That procedure automatically sets up the USB stick for swapfile / recording / timeshift during installation. Timeshift is now working perfectly again. All I can suggest is that you re-initialise your stick (menu>setup>system>storage devices>initialisation on my H2S with Wooshbuild). Hope you get yours sorted.

PS: My timeshift settings are as Grog mentions above with the exception of number of events = 3.
 

veronikkk

Newbie
Thread starter
Thanks motahed for your useful suggestions. So, you're saying you started experiencing the exact same issue, but things were fine before? My box was on OpenATV from the very beginning and I noticed this issue right away. Anyway, you think I should just try and re-initialise the stick? You also said the procedure you performed sets up the USB stick for a swap file, do you think I should create a swap file as well? I've never done that as I was advised against it.
does your iptv allow recording.?
as, in effect, timeshift is recording
yes, it records iptv just fine, but the issue only seems to affect HD channels with very high bit rates.
 

motahed

Newbie
Thanks motahed for your useful suggestions. So, you're saying you started experiencing the exact same issue, but things were fine before? My box was on OpenATV from the very beginning and I noticed this issue right away. Anyway, you think I should just try and re-initialise the stick? You also said the procedure you performed sets up the USB stick for a swap file, do you think I should create a swap file as well? I've never done that as I was advised against it.

Well, I can't say I know all the technical benefits or disadvantages but I am led to believe that put simply a swapfile is like having 'extra' memory available. As it allows a system to read and write data, it is dependant on the speed of the device (USB stick or HDD) so a swapfile can slow the machine down if the stick is slower than memory (which I guess it usually is) so that may be why you've been advised against creating a swapfile. However if the memory in your box is getting 'used up' then a swapfile would give you extra and maybe cure the problem. Not sure it will work for you but I don't think it can hurt to try.
 

veronikkk

Newbie
Thread starter
As a matter of fact, I checked the info panel today and took a few screenshots after noticing something about RAM usage. Basically, before timeshift kicks in automatically (after 1 minute, as per my settings), RAM usage looks like this
479b41dd9efcee98ac37d54d837def2c.jpg


Then it drops way down to about 10,000/20,000 and it stays like that when timeshifting.
547a5a3570d507a1917c37bf86c22ffb.jpg

Is this normal and could it possibly be causing this issue? Regardless, I'm gonna try and re-initialise the drive over the next few days, and then will create a swap file as well if the issue persists.
 

steptoe

TK Veteran
the swap works by allowing the RAM to overspill
the least used stuff, or longest since last used, gets spilled over into swap, thus allowing more RAM for the stuff required more urgently
 

motahed

Newbie
As a matter of fact, I checked the info panel today and took a few screenshots after noticing something about RAM usage. Basically, before timeshift kicks in automatically (after 1 minute, as per my settings), RAM usage looks like this
479b41dd9efcee98ac37d54d837def2c.jpg


Then it drops way down to about 10,000/20,000 and it stays like that when timeshifting.
547a5a3570d507a1917c37bf86c22ffb.jpg

Is this normal and could it possibly be causing this issue? Regardless, I'm gonna try and re-initialise the drive over the next few days, and then will create a swap file as well if the issue persists.

A swapfile will help increase that available memory (which is never a bad thing) but while timeshifting it is also 'space' available on the usb stick and the speed of the stick that will matter to you so let us know how you get on after re-initialising etc.
 

veronikkk

Newbie
Thread starter
Yep, timeshift seems to be working perfectly now after re-initialising the stick yesterday. I tested it out myself for a little while, and my folks just told me they've had zero freezing issues today as well. I didn't create a swap file. Thanks again everyone.
 

motahed

Newbie
Yep, timeshift seems to be working perfectly now after re-initialising the stick yesterday. I tested it out myself for a little while, and my folks just told me they've had zero freezing issues today as well. I didn't create a swap file. Thanks again everyone.

Good news, pleased you got it sorted. As for no swapfile... if it's not broke don't fix it :)
 

veronikkk

Newbie
Thread starter
A small update on this issue. After a few days, I started seeing rare freezes here and there during timeshifting once again. Nothing major, but still quite annoying when they occur. I finally noticed that this stick (128GB Transcend 3.0) causes the box to boot up in a weird way. What I mean is that the box jumps straight from 50 to 99 when booting up, and hangs there for a while (boot-up time is normal, though). Still, I tried changing the mount location to hdd2, and it did boot up properly and timeshifting worked fine, but the box then resumed skipping from 50 to 99 after simply restarting the GUI once. So, would you say this timeshifting issue has something to do with the USB stick? I mean, does enigma perform some sort of HDD check/preparation during the second part of boot-up? How do you explain the skipping, is it normal?

Anyway, I've tested this 128GB stick on my H2H (same openATV backup) and the same issues (skipping during boot-up and picture freezes when timeshifting) occurred as soon as I mounted it on that one. However, I've been using a 64GB stick (same make and model) for over a year on my H2H and it has worked flawlessly. And I've now tested this 64GB flash drive on my folks' box and it also works flawlessly, unlike the 128GB one. So, is the box for some reason unable to handle timeshifting on this larger stick or is it perhaps just a faulty unit? Downloads and recordings always play smoothly, though, and the stick is very fast, so I'm not sure about that. Of course, I've already tried re-initializing it and a swap file doesn't help either. Anything else I could try to get the box to boot up normally when this flash drive is mounted?
 

cactikid

VIP Member
e2 boxes are fussy on usb sticks to use and for flashing i stick with kingston , integral , and cruzer. recording and other stuff i would use externally powered 1 tb,but as you like small i would try another make as in recommended for box use and not chinese crap.
is usb in rear port?
 

veronikkk

Newbie
Thread starter
Thanks for the tips, cactikid. Yes, the stick is in the rear port.

So, you recommend using an externally-powered hard drive both for recording and timeshifting? I actually have a couple of those (1TB and 2TB), but I was advised against using hard drives for timeshifting, and since my folks do a lot of that, I opted for a large stick as they also download quite a bit of stuff. As for me, I don't care much about timeshifting, but never noticed any issue when timeshifting with my 64GB stick, and that's why I'm now thinking the box, for some reason, doesn't like this larger stick that my folks use instead, especially because of the weird behavior I described. I mean, is it normal that it just skips from 50 to 99 when enigma reboots? That doesn't happen when the 64GB stick (or smaller sticks for that matter) is mounted. Regardless, you think this type of issues are par for the course when using USB sticks in e2?
 
Top