coozer

Member
My PC did a windows 10 upgrade that took hours, now it has deleted one of my hard drives. Ive looked everywhere I can and it seems some file system is missing..

Looking in the bios at boot time I cannot see the disc...

There seems to be lots of stuff on the net that wants my money to fix this problem...

Anyone know how I can get the disc back? i dont have another pc to put it in, and I want to keep all the stuff thats on it. I only used it for storage but theres a lot there, years and years of it...
 

coozer

Member
Thread starter
Yep, tried all that and I can see the drive in disc management but it says its not initialised and when I click on it it says device does not exist...
 

christara

Member
Last edited:

coozer

Member
Thread starter
If I unplug it then plug it back in it reboots the pc, and its making a a noise.. a repeat 3 second beep.. does that mean anything?
Ive tried the AOMEI freeware but it just throws an error at me...
 

christara

Member
You could try this software to recover whats on the disk?

[2022] How to Initialize Disk without Losing Data?.

This is the area to read up on when looking at retrieving what data is on the drive.
Part 4: How to Initialize Disk without Losing Data?

Also have you looked in device manager to see if the drive is showing there?
If so try and look for update driver.

free stuff to try
Best Data Recovery Software – 2022 Reviews & Comparison

Plus if the drive your having problems with is an SSD could you try a different cable since I,ve had this problem before and the cable go,s faulty for what ever reason?
 
Last edited:

steptoe

VIP Member
It sounds as tho windoze hasn't mounted the disc when upgrading, a common issue it would seem, I've had this before during a Linux upgrade, and was a simple terminal command to auto mount on boot,
No idea how you would automatically mount on a windoze install tho, sorry.
 

frundlemud

Member
Run it as a slave drive on another pc to recover data, then you can reformat and filesystem should be recognised. sata driver issue?
 
Top