open vpn tsmedia

dsayers2014

VIP Member
hi i was having trouble watching movie 25 and other streams on ts media so i googled about adding proxys and found this on another forum and it worked straight away so i thought il,d share.

Ok, I was getting pissed off with proxies etc in TSmedia so I thought - what about VPN!
After a couple of hours playing I finally got it working and it works very well indeed!
lines still work fine as does 1channel - Movie4K - Icefilm - Movie25 and Simplymovies
first of all install openvpn - I'm running vix so menu/setup/system/network/openvpnsetup
next get your free vpn http://www.vpngate.net/en/ scroll down and pick a server of your choice (pick one with a lowish ping and obviously not UK) and download the openvpn config file,it will look like this xxxxxxxxx.ovpn - rename this file to Client.conf and ftp to /etc/openvpn - then go back to openvpnsetup and press the green button - after about 5 seconds the status should change from red(stopped) to green(running).
If you have a line running this will freeze for about 5-10 seconds while it redirects through VPN.
Have fun lads!!
 
Last edited:

giler

Registered
Trying to setup openvpn and it keeps coming back with feeds are down for maintenance.whats all that about?
 

Jonoowen

Registered
the openvpn suggestion no good for me

tried this numerous times with differnt ones still no joy tsemdia still dont work :( thanks for the suggestion though,

i am with virgin media maybe they have totally blocked this
 

sucmnsee

TK Veteran
Trying to setup openvpn and it keeps coming back with feeds are down for maintenance.whats all that about?
As it says vix are doing maintenance to the feeds so wont work until they're finished.
you can use tspanel/addons to find what u need tho

---------- Post Merged at 08:26 PM ----------

tried this numerous times with differnt ones still no joy tsemdia still dont work :( thanks for the suggestion though,

i am with virgin media maybe they have totally blocked this
Have u got tsmedia updated to latest build? No idea if it will help but should be anyway.
 

Jonoowen

Registered
hi, yeah i have got the tsmedia updates to the latest version, i havent got a clue what i am doing here the open vpn when i actiavte and it goes green i exit out and it switches itself back off
 

dsayers2014

VIP Member
You have to try different links that's how I got my openvpn working also when you ftp Client.conf make sure it's capital C and reboot before starting vpn. As for ts media I use movie 25 a lot of them work but you need to reboot box every couple of hours.
 

dsayers2014

VIP Member
Just Client.conf but I gave up on kodi and ts media months ago it was too slow and hardly worked
 
Last edited:

sb1980

Registered
I know this is an old thread, but just wondered if anyone has this working on a ZGemma H2H?

Everything seems to work absolutely fine - to the point where the VPN is active, however, when I set the VPN to autostart, and reboot the box, on boot, it starts going through the numbers on the front of the box, and sticks at 40 (have left it for about 20 minutes).

Its done this twice now, and the only way I can the box working again is by re - flashing it.

Am using sucmnsee back up of 3.2.027

Anyone any ideas?
 

sb1980

Registered
Thanks for the reply. I'll try that tonight - I'm pretty sure I couldn't connect via FTP when it was stuck - but not 100% - I was still half asleep!

It definitely only happens when I set it to auto start and reboot though.

My workaround may just be to start it, and then not reboot the box (leaving Auto start disabled), and seeing if it stays enabled when the box goes into / comes out of standby.

Slightly off topic, but is there a way to check that it is actually working? - i.e check what the external IP of the box is (just to be certain that it is actually connected to the VPN)? I'm new to all this, but don't think I've seen a web browser on the box which would allow me to check that.

Also, is there a list anywhere of what the numbers on the box mean when booting up? - I was thinking maybe 40 (which is what it sticks on) is something to do with the network config or something?
 

kiddac

Registered
When I was experimenting with this, some VPN conf files worked just fine, others as mentioned just totally crashed my box. It was a few weeks ago I tried this and have since deleted the files. Therefore I can't remember which source I used that worked. But for now I am not messing about with openvpns as its highly possible it will crash your box and a reflash is required. Fine if you do a full backup first. Wouldn't recommend it for someone who doesn't know what they are doing though.
 

No1gooner

TK Veteran
I done the same kiddac tried a vpn a couple of months back and all worked fine, the one I tried today just crashed my box and needed a re-flash good job I always have a back up to flash back to!
 

TerryB

Registered
Sorry for digging this up -
When I was experimenting with this, some VPN conf files worked just fine, others as mentioned just totally crashed my box. It was a few weeks ago I tried this and have since deleted the files. Therefore I can't remember which source I used that worked. But for now I am not messing about with openvpns as its highly possible it will crash your box and a reflash is required. Fine if you do a full backup first. Wouldn't recommend it for someone who doesn't know what they are doing though.
I have been using OpenVPN with a PIA account on my Solo2 but have noticed that my Solo2 will not restart. It will shut down, show the VU+ initial splash screen then the TV goes blank and the Solo2 display just shows VU+ Solo2.

The only way to get going is a reflash start up.

I have tested a restart after each stage of setting up and it all works fine until I actually run OpenVPN then it fails to restart.

Anyone any ideas?
 
Last edited:

nitro123

Registered
Hi guys does anyone know here how to check a openvpn IP address when it's running in the background?

Hi guys does anyone know here how to check a openvpn IP address when it's running in the background?
 
Last edited by a moderator:

bigfoot16

Registered
**** If you are not comfortable with Linux command line then stop reading. This is a guide only and I won't be providing support :) ******


I've recently setup OpenVPN on my Zgemma H2s running Woosh 4.00.2. Wanted to share the following as might be useful to others.

1) MENU -> SETUP -> SYSTEM - > NETWORK -> OPENVPN SETUP - install the OPENVPN client.

Don't press the Green button to Start the service yet.

2) Take your VPN configuration file, I'm using a paid service who provide both TCP and UDP connections. Pick the xxxxxxxxx.opvn file you want to use and ftp to the Zgemma box. (telnet and ftp credentials : default : username = root with no password). Place the file in

/etc/openvpn

3) Now, TELNET to the ZGEMMA box and rename xxxxxxxx.opvn to xxxxxx.conf

4) Next, edit the conf file using VI.

find the section "auth-user-pass" and edit to "auth-user-pass login.txt"

5) now create a login.txt file in the /etc/openvpn directory containing (change for your actual vpn username and password). It is advised to change perms of this file to make read only.

username
password

6) From the command line we are going to find your current ISP internet address. Issue the command.

curl http : // checkip. dyndns. com/ (remove the spaces from URL).



sometimes this command doesn't work - CTRL C it and retry until you get a response. Make a note of this IP address as we will compare after VPN started.

7) Now go back to the ZGEMMA box and change the DNS entries to match that of your VPN provider.

MENU -> SETUP -> SYSTEM - > NETWORK -> DEVICE SETUP -> NAMESERVER SETTINGS

if you are using DHCP you will need to change the permissions on /etc/resolv.conf (use : chattr +i /etc/resolv.conf). The reason for this is each time you restart the network or box, the DNS entries are overwritten with your default ISP entries. If DHCP disabled and using static IP then don't need to worry about this.

8) check the contents of /etc/resolv.conf to make sure entries changed.

9) Now it's time to test the VPN connection. Use the following command from /etc/openvpn

openvpn --config xxxxxxxx.conf

you need to look out for

Peer Connection Initiated with [AF_INET] <IP ADDRESS>
and
Initialization Sequence Completed

make sure no errors and connection isn't reset by remote host. With logging enabled I ran into lots of issues - so don't bother with logging in the /etc/init.d/openvpn script

10) Now open another telnet session. And try the curl command again.

curl http : // checkip. dyndns. com/


You should now see a different IP address which is that of your VPN.

11) Go back to the other telnet session and CTRL C to kill the vpn.


12) Nearly there. Go back to ZGEMMA box and now start the VPN and enable autostart from

MENU -> SETUP -> SYSTEM - > NETWORK -> OPENVPN SETUP


the start is just calling /etc/init.d/openvpn.

13) From telnet session check the following log

tail -f /var/log/messages

make sure the VPN connection is established.

You can test pulling out the ethernet cable and the VPN will recover (assuming your config file contains "resolv-retry infinite").

14) from telnet issue "reboot" and make sure box comes back up OK. DNS entries are still set to VPN and VPN initialised correctly.



I'm sure this could be improved and alternative approaches taken, but this is how I've setup currently. You might want to change the routing tables to prevent any connection out using default ISP if you are worried about dropped connections and your default IP getting revealed. TELNET = putty or other SSH client.

thanks
 
Last edited:

bigbak

Registered
You have to try different links that's how I got my openvpn working also when you ftp Client.conf make sure it's capital C and reboot before starting vpn. As for ts media I use movie 25 a lot of them work but you need to reboot box every couple of hours.
It doesn't have to be a capital C. OpenVPN will load all .conf files from /etc/openvpn regardless of name.
You also don't need to reboot. service openvpn restart is sufficient (same as enabling in the interface).

If you have a vpn with a password, put them in a separate file in the /etc/openvpn folder. I called my pass.txt. The first line is the username. The second is the password.
For usenetserver, the username would be [email protected]

Within the conf file, change the line
auth-user-pass
to:
auth-user-pass pass.txt

This will automate the login for you.
 
Top