Sharing HDD between two Zgemma h2s's - How to

grog68

TK Veteran
Forum Supporter
I've been asked how I've set up my two boxes too share one usb hard drive so that recordings can be viewed on either box so thought I would start a new thread.

I have 2 zgemma h2s boxes with wooshbuild 4.001 installed so my instructions are based on that but I assume other builds will be similar.

Box one is wooshbuilds standard setup with a usb hdd plugged into the back and mounted as /media/hdd, all recordings, timeshift and epg data etc is stored on the hdd. Nothing special.

Box 2 has wooshbuild 4.001 standard set up but with just a usb memory stick plugged in the back and mounted at /media/hdd and timeshift and epg data is stored on here as normal.

Now on box 1, I have turned off dhcp in network settings, Menu -> Setup -> System -> Network -> Device Setup -> Adaptor Settiings -> Use DHCP - NO, then green button to save. Exit out of the menu system and your network will restart. This gives your box 1 a permanent IP address so there is no chance of it changing if the box is rebooted.

Now on Box 2 you need to do the following:

Mount HDD thats on box 1 :

Menu -> Setup -> System -> Network -> Mounts Setup -> Mount Manager -> Network Browser, this should scan your network and you should see box1 on the list. Scroll down to box1 and click OK, select no when asked if a password is needed (even if you have password on box 1)

You should then see two items under your box1 entry, highligh HardDrive and click ok.again click no when asked if password is required. You will no see Mount Editor.

Go down each item, as you can see in the image below I have 'Mount using' set to FSTAB.

networkdrivesettings.jpg
Scroll down and you will be asked for username and password, username is root, if you dont have a password on your box1 (default) then leave password blank, then press green button to save. Keep pressing exit until you return to tv.

Now go Menu -> Setup -> Recordings and Timeshift -> Recording Settings. With Default movie location highlighted press OK. HIghlight Parent Directory and press OK, then highlight List of Storage devices as press OK again. Now highlight your network drive HarddiskZGEMMAH2S (maybe slightly different) and press OK. Scroll down to movie and press OK once again and then press Blue button to add it as a bookmark and then green button.

Now with Default movie location highlighted use left and right arrows and select /media/net/HarddiskZGEMMAH2S/movie and press green button to save.

Now exit back to TV screen.

Still on box 2 press green button to get plugin list up, scroll down to Movie Organisor and click OK. Use arrow keys to change enabled to no and press green button.

Press 'File List' on remote of box2 and highlight .. and press OK, repeat this until you get a alist of hdd, net, autofs. Highlight net and press OK button. Scroll down to the network drive and press OK again, highlight movie and press OK once again. You should now see all of the recordings on the hdd connected to box 1. Press exit until you get back to TV screen

I personally restart box 2 just to make sure all network settings are set, but I dont know if this is needed.

You should now be watch recordings on either box, as well as recordings made on either box will be stored in the same place.

Hope this help
 
Last edited:

contracts34

Registered
Hi grog68
Tried this earlier but only got as far as "Menu -> Setup -> System -> Network -> Mounts Setup -> Mount Manager -> Network Browser, this should scan your network and you should see box1 on the list" as Network browser wasn't there. I found it in another section but then followed the rest of your guide. I recorded something on box 2 but it isn't showing on box 1 hdd.
Had a few other problems as some of the steps outlined didn't seem to be there on my box.

I am using SkyQ skin on second box but can't see that being an issue.

Any ideas would be appreciated.
 
Last edited:

grog68

TK Veteran
Forum Supporter
Ah that might be my error, sorry, go Menu -> Setup -> Recordings and Timeshift -> Recording Settings. With Default movie location highlighted press OK. HIghlight Parent Directory and press OK, then highlight List of Storage devices as press OK again. Now highlight your network drive HarddiskZGEMMAH2S (maybe slightly different) and press OK. Scroll down to movie and PRESS OK AGAIN to take you into the movie folder and then press Blue button to add it as a bookmark and then green button.

Now with Default movie location highlighted use left and right arrows and select /media/net/HarddiskZGEMMAH2S/movie and press green button to save.



Let me know if that fixes the problem. I am now updating my first post
 

grog68

TK Veteran
Forum Supporter
On my box the blue button is Add Bookmark. What build are you using?

Edit: Below is screenshot of my box 2 when setting default movie location, I've moved to the Movie folder on the hdd connected to box 1. (Note my hdd is named HarddiskFRONTROOM rather than the default HarddiskZGEMMAH2S
defaultmovielocation.jpg
Once I'm in the movie folder I pressed the blue button to create the bookmark which you can see in the bottom list.
 
Last edited:

grog68

TK Veteran
Forum Supporter
I'm on latest whoosh build
So am I, Are you seeing anything like the screen above? basically you need to add a bookmark for /media/net/HarddiskZGEMMAH2S/Movie so this can be selected to set the default recording folder.
 

grog68

TK Veteran
Forum Supporter
Can't remember off hand but somewhere like Setup - Network - Mount Management you should be able to delete the mount pointing to your box 1 hdd and then start again from the point 'Mount HDD thats on box 1' in my first post.

Off now and won't be back online until Saturday.
 

danmed

Registered
Now on box 1, I have turned off dhcp in network settings, Menu -> Setup -> System -> Network -> Device Setup -> Adaptor Settiings -> Use DHCP - NO, then green button to save. Exit out of the menu system and your network will restart. This gives your box 1 a permanent IP address so there is no chance of it changing if the box is rebooted.
Hey Grog, unless you have something magic going on on your network, they will have to set a static IP manually or have their Router dish out a specific IP to the box MAC address.. i know you probably know this but to someone not clued up on networking, this may confuse them..
 

contracts34

Registered
Hi grog,

Almost there. Anything I now record on box 1 (with the hdd) can be seen and accessed from both boxes. However, anything I record from box 2 doesn't appear on the hdd. When I press file on box 2, there is an additional directory at the top which contains all the contents of my hdd (backup files etc) and it's dumping box 2 recordings in there, but box 1 can't see it. I can then move the recording via the green button to movie folder and they then appear accessible on both boxes. I can't however seem to change the path to direct them there automatically.
 
Last edited:

grog68

TK Veteran
Forum Supporter
Now on box 1, I have turned off dhcp in network settings, Menu -> Setup -> System -> Network -> Device Setup -> Adaptor Settiings -> Use DHCP - NO, then green button to save. Exit out of the menu system and your network will restart. This gives your box 1 a permanent IP address so there is no chance of it changing if the box is rebooted.
Hey Grog, unless you have something magic going on on your network, they will have to set a static IP manually or have their Router dish out a specific IP to the box MAC address.. i know you probably know this but to someone not clued up on networking, this may confuse them..
Oh, I haven't lol, When I switched dhcp off on the box it used the IP address that dhcp had assigned, rebooted box and VM router (not at same time) and it's always connected with same IP. I'm not a network expert so might just have been lucky, my post was just how I set it up. I will check my router later.

Hi grog,

Almost there. Anything I now record on box 1 (with the hdd) can be seen and accessed from both boxes. However, anything I record from box 2 doesn't appear on the hdd. When I press file on box 2, there is an additional directory at the top which contains all the contents of my hdd (backup files etc) and it's dumping box 2 recordings in there, but box 1 can't see it. I can then move the recording via the green button to movie folder and they then appear accessible on both boxes. I can't however seem to change the path to direct them there automatically.
It sounds to me like you have created a bookmark for /media/net/HarddiskZGEMMAH2S but not /media/net/HarddiskZGEMMAH2S/movie.

Now go Menu -> Setup -> Recordings and Timeshift -> Recording Settings. With Default movie location highlighted press OK. HIghlight Parent Directory and press OK, then highlight List of Storage devices as press OK again. Now highlight your network drive HarddiskZGEMMAH2S (maybe slightly different) and press OK. Scroll down to movie and press OK once again and then press Blue button to add it as a bookmark


Once you have done that you should see the path to /media/net/HarddiskZGEMMAH2S/movie in the list of bookmarks at the bottom of the screen. If you do press the green button then you should be able to select it as your default recording location
 

contracts34

Registered
Hi Grog

Ran through the setup again and finally got it working okay. Only thing I can think of is that once I got down to the "movie" I must have pressed OK before the blue button to add a bookmark. If that's what I did first time around, it will have gone to a further sub-folder.
Anyway, up & running and thanks for both your assistance and a great set up/instruction guide.
 

grog68

TK Veteran
Forum Supporter
Hi Grog

Ran through the setup again and finally got it working okay. Only thing I can think of is that once I got down to the "movie" I must have pressed OK before the blue button to add a bookmark. If that's what I did first time around, it will have gone to a further sub-folder.
Anyway, up & running and thanks for both your assistance and a great set up/instruction guide.
Glad you got it sorted mate
 

fayhal

Registered
I tried sharing the HDD between 2 boxes one connected with cable and the other WIFI but the WIFI box was taking too long to read/write back to the HDD so just got another drive.
 
Top