VPN Conf Importer

urie

TK Veteran
TK Supporter
@Grog had a look at the master script looks like dsayer has windscribe configs strored on his github there is no direct link to windscribe website for configs.
Windscribe Its another vpn provider that uses openvpn config genarator so login needed.
 
Last edited:

grog68

VIP Member
TK Supporter
Thread starter
@Grog had a look at the master script looks like dsayer has windscribe configs strored on his github there is no direct link to windscribe website for configs.
yea I see it on @dsayers2014 script, not sure why I missed it, will add it tomorrow
 

grog68

VIP Member
TK Supporter
Thread starter
i use 2 vpn's windscribe and also ufo any chance of adding?
grog I think link will be in dsayers config scripts

1) Nord VPN
2) IP Vanish
3) Digibit
4) PureVPN
5) PIA VPN
6) Windscrape (think this is typo meant to be Windscribe) as I searched and cannot finde Windscrape VPN
7) SurfShark
8) TorGuard
9) Ivacy
10) Quite
Windscribe has been added, if you could test and confirm it works it would be great thanks
 

grog68

VIP Member
TK Supporter
Thread starter
Hi mate is it possible to ad Vpnunlimited?
If you log into vpn unlimited are you able to download their conf/opvn files, as someone who hasn't signed up it appears they don't allow conf file downloads in which case we can't incorporate it within this plugin
 

pabloescaban

VIP Member
TK Supporter
Has there been an update to this plugin?
I'm using v 0.2
A friend is trying to install it on newest at and GB FR, it's coming up with v0.8 and won't install.
Constant blue screen each time it's accessed.
In the crash log it says there's a problem with "grogimportcred"
 

grog68

VIP Member
TK Supporter
Thread starter
Has there been an update to this plugin?
I'm using v 0.2
A friend is trying to install it on newest at and GB FR, it's coming up with v0.8 and won't install.
Constant blue screen each time it's accessed.
In the crash log it says there's a problem with "grogimportcred"
Nothing changed with the plugin since december but it is version 0.80, versions basically changed as I added more sites.

Which vpn server is he selecting? I heard today digibit url has changed recently and I've not updated that yet.

Is he running ATV 6.4, 6.5 or vix?
 

pabloescaban

VIP Member
TK Supporter
Nothing changed with the plugin since december but it is version 0.80, versions basically changed as I added more sites.

Which vpn server is he selecting? I heard today digibit url has changed recently and I've not updated that yet.

Is he running ATV 6.4, 6.5 or vix?
Atv 6.4 on ZG H7
Not got to stage of adding any vpn.
As soon as he tries to open conf importer the box crashes BSOD.
Flashed plain atv a few times and GBFR a few times and importer doesn't work at all.
 

grog68

VIP Member
TK Supporter
Thread starter
Atv 6.4 on ZG H7
Not got to stage of adding any vpn.
As soon as he tries to open conf importer the box crashes BSOD.
Flashed plain atv a few times and GBFR a few times and importer doesn't work at all.
hmm that's odd, I flashed my vu only a couple of weeks ago and the plugin loads fine.

I am flashing an H7C later this morning for someone so will see what happens
 

grog68

VIP Member
TK Supporter
Thread starter
well, something not right, installed on h7c and get the BOD, install on my vu+ and works fine. both 4k boxes so nothing to do with arm etc.

For some reason the H7 isn't writing variables to the settings file for some reason, I'm looking into it
 

grog68

VIP Member
TK Supporter
Thread starter
it makes no sense, 2 lines of code not liked by h7, fine on other boxes, checked syntax and that's fine.
 

grog68

VIP Member
TK Supporter
Thread starter
ok get same error on h7 if installing vix rather than ATV.

It's a wierd box specific issue as just reflashed my VU+ with GBFR and the plugin loads fine.,
 

pabloescaban

VIP Member
TK Supporter
ok get same error on h7 if installing vix rather than ATV.

It's a wierd box specific issue as just reflashed my VU+ with GBFR and the plugin loads fine.,
But I sent him v0.2 and that was the same so I'm not sure it's the plugin but maybe oatv 6.4?

V0.2 works on my H7c flashed in August
 

grog68

VIP Member
TK Supporter
Thread starter
But I sent him v0.2 and that was the same so I'm not sure it's the plugin but maybe oatv 6.4?

V0.2 works on my H7c flashed in August
if you install version .8 it should work as nothing has changed in the plugin for 2 months


If it's only specific boxes maybe a dependency on a driver if it works on older images
I'm not sure as the error occures when it adds options to the plugin screen, comment the line of code out and the plugin loads, the only problem is the two options are needed.
 

grog68

VIP Member
TK Supporter
Thread starter
These two lines are causing the issue on the H7c, comment them out and plugin loads but you can't obviously select vpn provider:

Code:
config.vpnmanager.grogimportcred = ConfigYesNo(default=False)
config.vpnmanager.grogsvpn = ConfigSelection(default="select",choices=[("select",_('Select VPN')),("airvpn",_("AirVPN")),("cactus",_('Cactus VPN')),("digibit",_('Digibit')),("fastest",_('Fastest VPN')),("ipvanish",_('IP Vanish')),("ivacy",_('Ivacy VPN')),('ivpn',_("IVPN")),("lime",_('Lime VPN')),("monster",_('Monster VPN')),("nord",_('Nord VPN')),("pia",_('PIA')),("privado",_('PrivadoVPN')),("purevpn",_('Pure VPN')),("safervpn",_('Safer VPN')),("slickvpn",_('Slick VPN')),("surfshark",_('SurfShark')),('torguard',_("Torguard")),('vypr',_('VyprVPN')),("windscribe",_('Windscribe VPN')) ])
 
Top