gigablue openatv mgcamd_135a help

imraan196

Newbie
Hi all,

I just cannot seem to get my mgcamd working with my n line, it was working last night however when i restarted the box its now not working, i have checked all tjhe guides and edited the files correctly please can someone help

I am just getting no ecm info found

below is the contents of the newcamd.list i have in /usr/keys and i have blurred out the lines

CWS_KEEPALIVE = 300CWS_INCOMING_PORT = 21000CWS = servername.ddns.net portnumber uername password 01 02 03 04 05 06 07 08 09 10 11 12 13 14

below is the contents of mg_cfg which i donloaded and not changed from the techkings website
# EMM messages
# 00 don't show any EMMs (default)
# 01 show only valid EMMs
# 02 show valid and bad EMMs with complete data display
M: { 01 }

# ECM messages
# 00 don't show anything about ecm
# 01 normal mode, show pids processed, decoded ecm and cw
# 02 verbose mode, show valid and bad ECMs with data
C: { 01 }

# AU
# 00 disable, no emm pids processed
# 01 enable, emm pids always processed for soft-au and shared cards
# 02 auto, emm started only if channel cant be decoded
# 03 process emm pids for network cards update only
A: { 02 }

# key update (sum 01 or 02 with 04)
# 01 update only new keys, default setting
# 02 update all keys (used for valid PMK checking)
# 04 enable TPS au
# + tps SID, which pmt pid contains au pid
U: { 01 } 0x12c0

# config files folder (softcam, autoroll, ignore/priority)
# 00 files in /var/keys
# 01 files in /tmp
T: { 00 }

# network mode, use summ for several clients
# 00 no network (default)
# 01 newcamd netclient
# 02 radegast netclient
# 04 camd3 netclient
# 08 gbox netclient
# 32 cccamd netclient, card list saved as /tmp/cccamd.info
# (ECM only, supported server version up to 2.1.1, later not work)
G: { 33 }

# network retry, use summ for several options
# 00 disable
# 01 retry every new ecm
# 02 try to connect to offline shares every Q: seconds
# 04 try to detect and fast reconnect to lost (and not used atm) server
# + XX messages number and YY seconds to reconnect
# mg will reconnect to server, if no answer to last XX ecm/keepalive or
# if no answer for last ecm or keepalive sent for YY seconds
# set to 0 to disable
N: { 07 } 5 30

# network ecm timeout in seconds
K: { 10 }

# newcamd dead routes connect retry, sec
Q: { 600 }

# network shares priority
# 00 gbox, newcamd, cccamd, radegast, camd3 (default)
# 01 camd3, radegast, cccamd, gbox, newcamd
# 02 cccamd, newcamd, camd3, gbox, radegast
P: { 00 }

# on screen display type
# 00 No OSD (default)
# 01 neutrino
# 02 enigma
# 03 relook
# + user password for http auth
O: { 00 } username password

# on screen display Options, summ of:
# 01 show emu ecm
# 02 show network shares messages
# 04 show decoding failed / fta
# 08 show emm keys update
# + web port to use for osd
S: { 03 } 80

# Log option, summ of:
# 00 off
# 01 network udp log
# 02 log to console
# 04 file, appended ! delete it by yourself, before it eat all your hdd
# + IP udp-port log-file-name
L: { 00 } 172.16.1.1 28007 /tmp/mgcamd.log

# keep ecm cache, seconds
# every cache entry takes 28 bytes, so 24h cache will take *only* 240-400kb of memory,
# for openbox/elanvision users with remote shares make sense to set it higher than default value,
# to not hammer cards while timeshifting or playing crypted recordings.
E: { 15 }

# cache option, summ of:
# 00 Off (default)
# 01 Ecm pids cache, store pids used to decode in /tmp/ca_cache.list at exit, load at startup, same syntax as restore.list
# 02 Ecm data cache, remember CW for (E:) time
# 04 Emm cache for network cards, do not resend the same emm twice, cache not cleared until restart
H: { 07 }

# reread files, summ of:
# 00 No (default)
# 01 reread config file on channel change (including priority and ignore, but not replace/cache)
# 02 reread SoftCam.Key on channel change
# 04 reread SoftCam.Key if file changed
R: { 00 }

# debug, summ of
# 00 off (default)
# 01 debug ecm
# 02 debug emm
# 04 debug network ecm
# 08 debug network emm
# 16 debug network login
# 32 show mem/cpu stats every 1 min
# 64 add timestamp to log messages
D: { 00 }

# box type
# 00 autodetect, change only if you think wrong type detected.
# 01 dbox2
# 02 dreambox
# 03 triple-dragon
# 04 relook
# 05 openbox
# 06 dreambox/mips
# 08 stapi/kathrein
# 09 stapi/ipbox
# 11 stapi/openbox
B: { 06 }

# map all 180x nagra caids to 1801
# default is 01
F: { 00 }
 

dave100

TK Veteran
TK Supporter
It need to look like this one after the other
CWS_KEEPALIVE = 300CWS_INCOMING_PORT = 21000
CWS = servername.ddns.net portnumber uername password 01 02 03 04 05 06 07 08 09 10 11 12 13 14

if this is correct your line may be dead or you need to restart you cam box & router
 

cactikid

VIP Member
first thing i would try is network test to see if all green.
reboot box and router.
stop/start cam and make sure its on autostart.
multi tuner boxes should be using 1.38.
 

imraan196

Newbie
Thread starter
dave100 the contents of newcamd.list is like that there is no space after 21000 and CWS = servername and theres no spaces after 300 and CWS
i have restarted the box multiple times,

cactkid how do i check to see if the cam autostarts? i am now trying to restart the router

thanks for the response
 

dave100

TK Veteran
TK Supporter
first thing i would try is network test to see if all green.
reboot box and router.
stop/start cam and make sure its on autostart.
multi tuner boxes should be using 1.38.

Mgcamd 1.35a works great on my dm500c
 

imraan196

Newbie
Thread starter
the cam does restart automaticallly
restarted the router amd the box again no joy
did network test everything was fine also can play bbc iplayer from iptv

the line cant be dead becasue it was active yesterday and i use another line from the same guy on another box
 

southsimon

TK Veteran
why don't you just have -

CWS_KEEPALIVE = 300
CWS = servername.ddns.net portnumber uername password 01 02 03 04 05 06 07 08 09 10 11 12 13 14
 

southsimon

TK Veteran
I would be inclined to install 1.38r5 or better still just use oscam, I switched a box over couple of days ago seems to run smoother on oscam.
 

cactikid

VIP Member
the cam does restart automaticallly
restarted the router amd the box again no joy
did network test everything was fine also can play bbc iplayer from iptv

the line cant be dead becasue it was active yesterday and i use another line from the same guy on another box

swap lines over to see working box not working and not working to working.
another line would say to me you have another one and not multiroom.
are the ddns blocked as before when we had loads of people who got blocked and servers had to modify their end for users to work?
 

imraan196

Newbie
Thread starter
Lol I thought I was and I got really happy but oscam works on and off, when I restart my box i have to restart the cam and wait literally 5 mins for it to start then it turns off again and I have to restart the cam again and sometimes it works and sometimes it doesn't, I am really getting frustrated now and I work in IT ! Any suggestions ? I followed all the instructions from the oscam thread I think I might just re image the box and start from scratch
 

southsimon

TK Veteran
I have had issue myself with mgcam 1.38r1 till I went to 1.38r5 which had auto cam start. You might not have the right oscam setup, but I would be inclined to flash a fresh new image without using restore settings and start from scratch. Someone with your IT knowledge should find that a doddle lol !!
 

imraan196

Newbie
Thread starter
Haha I know but I don't want to brick a 300 quid box thanks for everyones help

(Il probably need more) lol
 

southsimon

TK Veteran
Not sure which model of gigablue you have, but the latest vix 5.0.025 has mgcam 1.38r5, I be amazed if it didn't work after a new flash?
 

imraan196

Newbie
Thread starter
Not sure which model of gigablue you have, but the latest vix 5.0.025 has mgcam 1.38r5, I be amazed if it didn't work after a new flash?
wow okay i flashed the box to openvix latest version isntalled 1.38r5 still nothing ! can you attach your mg.cfg file and the newcamd.list file please :)
 
Top