Heinz - Enigma2 catchup plugin

oottppxx

Registered
dont know what it was but its working as normal now thanks
Providers do have issues on catchup sometimes, a famous one just had those recently and it's fixed in the meantime, maybe that's the one you use.

Regarding grey vs white, that's a system setting: in theory, they should all be grey except, eventually, the last one; grey just means that the show has ended, white means it's either ongoing or hasn't started yet (at least that's the behavior on openatv with the default metrix skin).
 

Almighty Mick

Registered
Has anybody been able to get the record working? I press the green button but it never records or goes into the queue. I have two different boxes and both are the same.

Any ideas?

Edit : Actually the Red button records DOH.....I was trying the green button
 
Last edited:

oottppxx

Registered
Has anybody been able to get the record working? I press the green button but it never records or goes into the queue. I have two different boxes and both are the same.

Any ideas?

Edit : Actually the Red button records DOH.....I was trying the green button
Yes, either the red button or the "record" button should queue the show for local recording.
 

spc

Registered
oottppxx, excellent plug in that i have used for some time, but have one question, one of my providers has recently introduced catch-up but if selecting i get message "matching but unsupported stream (transient error or unsupported provider"). Is there a fix - does the provider need to add some flag etc? their catch-up works fine on apk and mag, and my other providers catch-up works well on Heinz
 

oottppxx

Registered
oottppxx, excellent plug in that i have used for some time, but have one question, one of my providers has recently introduced catch-up but if selecting i get message "matching but unsupported stream (transient error or unsupported provider"). Is there a fix - does the provider need to add some flag etc? their catch-up works fine on apk and mag, and my other providers catch-up works well on Heinz
I'm guessing it's an xtream-codes compatible provider, if so put the following URL in a browser, replacing the HOST, PORT (if applicable), USER, and PASS parameters with your own values, and see what is returned:

http://HOST:PORT/player_api.php?username=USER&password=PASS&action=get_live_streams&start=99990000000000

If nothing, or some error, that's the issue.
 

spc

Registered
http://HOST:PORT/player_api.php?username=USER&password=PASS&action=get_live_streams&start=99990000000000
Hi Thanks for the info, so you are right that url only takes me to web search, guess need to talk to provider.

Update, i miss edited the copy paste so had a space in line, now it connects and comes up with the playlist, so problem must be elsewhere.

Further update, now working fine having tried all stream type settings within Heins i then changed provider stream to his http option from the https one and hey presto that sorted it
 
Last edited:

oottppxx

Registered
Hi Thanks for the info, so you are right that url only takes me to web search, guess need to talk to provider.

Update, i miss edited the copy paste so had a space in line, now it connects and comes up with the playlist, so problem must be elsewhere
Go to Heinz settings, activate debug, try getting catchup from the provider and take a peek at the file left in /tmp. Don't forget to disable debug in the end.
 

spc

Registered
Go to Heinz settings, activate debug, try getting catchup from the provider and take a peek at the file left in /tmp. Don't forget to disable debug in the end.
Thanks for quick replies, i am now sorted, see my second update. it was https versus http stream format causing the issue
 

oottppxx

Registered
Gad you're sorted, I'm guessing the https port was explicitly called out in the URL and http uses a default port? So Heinz was trying to talk http to an https port and got no reply...

If xtream-codes providers are delivering via https (and the catchup api/streams are also available via https), I probably should change the code to contemplate that, currently I gobble the port with the host, but not the protocol, which is hardcoded as http.
 

rpidemon

TK Veteran
Forum Supporter
Heya Oottppxx,

I’ve clicked on the links to download Heinz and it’s come up 404 page not found?

Any chance you can advise or point me to where I can download it.

Many thanks in advance.
Be a shame if he has called it a day with this plugin as in my opinion it was one of the essentials for enigma 2 iptv viewing.
 

claw2k

Registered
Correct, you can access my enigma2 stuff at oottppxx/enigma2, just follow the links and make sure to download the proper file, not a Github HTML page (a common mistake).
OK Great

so I take it I navigate to this page and then hit download to get the actual ink file?
 

spanner123

Registered
Hi @oottppxx Just tried your bigmac plugin mentioned by @hedges2016 and it's great once you mess about with the settings. One improvement if it can be added would be to disable the infobar popping up when stream restarts otherwise all good!
 

hedges2016

TK Veteran
Think u need to turn off show info bar on channel change in settings
And what settings in the plugin did u change
Might help others out
 

spanner123

Registered
Thanks hedges, I have now turned off infobar on channel change although it is nice to have it for normal channels. The settings that seem to work best at the moment are poll interval 10, RX queue to 128 and total probes to 0 (disabled). Not definitive but works much better than default settings for me.
 
Top