Is The Edision OS Mega the right one for me?

meliam112

Newbie
Hi, I've been a long time reader of the forums and after finally ditching Uncle Rupert's gang I've taken the plunge and signed up.
I don't know much the subject being mostly used to Android/Kodi box set ups so please be gentle :)

As mentioned I've read through many forum threads and a lot came close to answering my queries but being unsure of etiquette and one other particular need I didn't want to butt in.

I 'think' I'd like to buy the Edision OS Mega, it sounds like it would suit my needs, record 2 progs while watching another.
I'd like to use the 3rd input as a Freeview HD feed (so 2 Satellite, 1 Terrstrial) I believe from what I've read that's possible?
My main TV is a Pioneer plasma, (one of us will die first it's the only way we will be parted) its only shortfall is its SD tuner and poor digital signal, so we always watch TV using the old S*y box. Other tv's & equipment elsewhere in the house (Humax pvr) can pick up Freeview without problem so it's obviously a weakness with this tuner box.

So that was my reason for picking the Edision above others, I want it to 'virtually' replace my TV's main tuner as well as having the satellite and recording capability (with a hard drive).
Have I made a wise choice or are there others I should be considering? Obviously 4K isn't needed for the Pioneer screen but if the hardware's better??

I've seen the Edision for sale in a 'World' where people have recommended but being a novice it comes with offers of things I don't understand yet like OpenViX, OpenPli & Open ATV.
Has anyone a thought on which option if any to choose? I think I read somewhere else about this but wondered if me needing the Freeview option made any difference?
Also would it be advisable to get the HDD installed by the seller to avoid any doubts re. future (if any) warranty claims?

Sorry if all that's too long, I feel like I haven't even touched the surface :)
Also thanks to those who've already helped me, even though you don't know it yet, you brought me here :)
 

Janso

TK Veteran
Yes it's possible to have the third tuner set up as terrestrial. It won't be a problem.

As for installing the hard drive, if you feel confident doing it yourself, do so, it'll save you a few quid.

Images, just try a few out - or there's the Willobuild that's already set up and you just have to amend a few settings to suit your setup.
 

maxal

Member
I have mine set up with Willos build and my third tuner is set up as terrestrial which works well for me so I would recommend the OS-Mega
 

meliam112

Newbie
Thread starter
I have mine set up with Willos build and my third tuner is set up as terrestrial which works well for me so I would recommend the OS-Mega
Much appreciated. Did you buy with OpenViX or OpenATV installed, or does none of that matter if you're going to install something like Willos build?
Sorry if that's a dumb question, I just want to get things right from the start.
 

danlou

Member
Yes, the osmega will suit you down to the ground. It's pointless you investing in a 4K box yet as a) you don't have a 4K TV and b) there is no real 4K programming out there at the moment in terms of c/s

The OSmega is a solid box physically and functionally, fast boot-up and has the added benefit of IPTV via IPTV Player and full Kodi so that means you can use mostly any image out there (I personally use Paradox, neat and uncluttered plus all the major add-ons such as NJM, Sports devil etc for sports)
My only gripe is the remote control - you have to be almost line of sight for it to register so i may opt for a Harmony replacement.
My configuration is 2 sat and freeview using CrossEPG with built-in 500gb hdd
All works flawlessly. Highly recommend.
 

maxal

Member
Hi Danlou, you have a similar setup to me but I use Oblivion Kodi build and I use the remote from the Zgemma H2s and I agree it's a top notch box
 

fbaggy

Member
I too have the Mega and can thoroughly recommend this box, as for the HDD installing your own 2.5" doesn't invalidate the warranty as far as I am aware but I did opt for it to be installed by the seller you mention in the OP. You can have it pre-installed with any of the builds but if you then flash a build a build like Willo's then that will overwrite it, if you make a back up before flashing you can always go back.

Bottom line is it easy to become overwhelmed with all the jargon and mumbo jumbo but to get a box up and running as you have described is fairly straightforward and there are always willing helpers on here if you get stuck

Cross to the dark side you wont regret it...........
 

meliam112

Newbie
Thread starter
I've just crossed fbaggy, bought the box about 15 minutes ago :)
Very grateful, followed everyone's suggestions, no point asking for advice if you're gonna ignore it is there?

I do try to make back ups of everything I use but where would I start here, how's it done?
This may be another daft question but when I eventually get around to making back-ups, installing builds, lines and other stuff (whatever it/they may be called), how many & what size USB's will I need and does each task need to be on a seperate USB?
I only ask so that if I need to I can go and buy a few and get them ready for my box coming and also keep them all safely out of the way of my kids, first one they see they pick up take to school and stuff the consequences.
I'll have to go on a fresh forum look now as a box owner :yes!:

That's also a bonus, I hadn't realised the Kodi on this was so usable and thought it was still beta-ish and ropey. I don't usually use builds though, just configure my own but I'm guessing it might be the easier option on these?

When the box arrives I'll have loads of questions, as you say fbaggy getting through 'the jargon' but it's been a great start with lots of help, thanks.
 
Last edited:

Willo3092

VIP Member
You can make an image backup on the internal HDD and just copy it over to your PC vis FTP or using the Windows network.
You can then put it on a USB stick to reflash if necessary.

MAKING AN IMAGE BACKUP ON ViX

MENU > SETUP > VIX > IMAGE MANAGER

Click Green button 'New Backup'.

This creates a complete cloned image of your setup.
To restore in the future, just highlight the entry and click the blue button to restore.
(the backup folder is /media/hdd/imagebackups/)

You can copy the zip file to your PC and extract it to a USB stick to restore from USB.
It is good practice to do this in case your receiver fails to start.


USEFUL BACKUP LOCATIONS: (If you just want to copy stuff to your PC)
usr/keys/ - lines
etc/tuxbox - oscam lines
etc/enigma2/ - bouquets & timers
usr/share/enigma2/ - skins
 
Last edited:

meliam112

Newbie
Thread starter
Got my box last Thursday, great service very pleased :)
Apologies for not posting more I know (or I hope) threads like these help out not just me but other naive new starters like me in the future.
I've switched on my mega to make sure it works but nothing else up to now, I've been busy reading the forums and also watching the remaining contents of my S*y planner before it gets cut off :)

That tells you I can't put my Edision in its final place yet but I could work on it at a former multi room connection. If I used that Satellite connection is it ok to set my box up then in a couple of weeks time unplug, disconnect and move it without losing any of its settings?
 

maxal

Member
Congratulations on your choice of box, enjoy. Yes what you want to do is fine you will not loose any settings.
 

meliam112

Newbie
Thread starter
Hi again. Things didn't get off to a good start, had trouble getting the image to fit the screen properly (not resolved) and then got caught in an endless loop with the epg. I gave up until I could get a download of Willo's build, I've just managed to get that, much appreciated thanks Willo, so I hope things go smoother from now on.

Blasted migraines over the years have and continue to rob me of my short term memory so if anyone has any useful tips or hints it helps me enormously to see them in writing on the days that I am able to use a PC, so thanks for all the advice so far.
 

meliam112

Newbie
Thread starter
Thanks to Willo I've installed his build, great stuff with clear instructions to follow, I feel like I'm finally getting somewhere now.

I do have a couple of issues, I can't seem to get the autobouquet E2 set for my region, Humber. I even tried N.Yorks but it refuses to change from Central, as far as I know I've followed the instructions, it says Humber and then does the search but no channels change, am I missing something obvious?
Also as I haven't got round to lines and all that yet the channels are all out of the order I think they should be e.g. 120 is ITV 4 HD & obviously blank, should this not be ITV 4 SD as that's what's active?
I do want to get a line etc eventually so perhaps this isn't important? I just want to get the basics right first, I'm finding myself a bit, no a lot out of my depth.

One final question for now if I may, as I intend to use this as a 2 sat & 1 freeview box, as several others here already do, how do I switch direct from the sat tuners to the freeview using the remote? Do I need to install something else for the Freeview side of things? I saw Danlou mentioned something about CrossEpg.

Sorry for the edit, got one more problem, I just tried recording for the first time and discovered my 500gb hard drive only has 33% free space left. Don't know what I've done? Seems to be 2 steps forward 2 back at the moment.
Further edit so not to waste anyone's time, I cut power to the box, restarted and I'm back up to 99%.
This is all new to me so hope explaining this helps someone else.
Thanks.
 
Last edited:
I also got myself an OS Mega over the last few days, with a 1TB internal hdd from the supplier. Like the OP I also flashed Willo's image (fab build Willo much appreciated!). The only problem I have, is I am having the curious hdd space loss issue just like the OP.

I have found that hdd space is disappearing at vast rate (far beyond programmes recorded). I have checked hdd drive format (it is clearly shown as ext4 within Mount Manager). I have also re-initialised the hdd using the PlugIn, and reflashed the build multiple times, with no luck. I have tried to monitor file space used with both Filezilla and the Dream-Explorer PlugIn, both of which confirmed that the recorded programme sizes are as expected and do not account for the huge hdd space loss (~20GB in a few hours, it went down from 99% to 33% free after a couple of days). I have even redirected timeshifting and swap files onto an external 16GB usb drive formatted as ext4, trying to isolate those activities as possible cause, with no effect.

Incidentally when I examined the hdd directory by directory I see no file size that can explain the huge disc space consumption.

Like the OP, I found that I can recover the "loss" space by a restart of the box. I also found that a Filesystem check within System / Storage devices can also recover the lost space.

Obviously I have got to find out what is gobbling the disc space in secret, and stop it. Any suggestion would be gratefully received!!

Cheers!
 

fbaggy

Member
I also got myself an OS Mega over the last few days, with a 1TB internal hdd from the supplier. Like the OP I also flashed Willo's image (fab build Willo much appreciated!). The only problem I have, is I am having the curious hdd space loss issue just like the OP.

I have found that hdd space is disappearing at vast rate (far beyond programmes recorded). I have checked hdd drive format (it is clearly shown as ext4 within Mount Manager). I have also re-initialised the hdd using the PlugIn, and reflashed the build multiple times, with no luck. I have tried to monitor file space used with both Filezilla and the Dream-Explorer PlugIn, both of which confirmed that the recorded programme sizes are as expected and do not account for the huge hdd space loss (~20GB in a few hours, it went down from 99% to 33% free after a couple of days). I have even redirected timeshifting and swap files onto an external 16GB usb drive formatted as ext4, trying to isolate those activities as possible cause, with no effect.

Incidentally when I examined the hdd directory by directory I see no file size that can explain the huge disc space consumption.

Like the OP, I found that I can recover the "loss" space by a restart of the box. I also found that a Filesystem check within System / Storage devices can also recover the lost space.

Obviously I have got to find out what is gobbling the disc space in secret, and stop it. Any suggestion would be gratefully received!!

Cheers!
what firmware version are you using, i had this issue with Open Vix 4 but 5.0.002 seems to have resolved it
 

siilver

TK Veteran
Was looking at one myself, but don't really want to spend that much
£179 ?

What else is in triples
 

meliam112

Newbie
Thread starter
I'm on 5.0.002 fbaggy so hope it's sorted itself.
Still can't get my local epg even though it says Humber i'm watching central & east midlands, anyone got a clue where i'm going wrong?
Just how do you get onto the terrestrial tuner and set that seperate epg up? I'm baffled.
Also getting blanked by kodi, downloaded the plugin but it won't launch.
 
what firmware version are you using, i had this issue with Open Vix 4 but 5.0.002 seems to have resolved it

Hi fbaggy many many thanks for the suggestion! It was on version 4.2.030 per Willo's 7/2/2017 build image for the box (and which executing Software update under Setup did not change). Based on your suggestion, I have just gone ahead and updated to version 5.0.002 from WoS, and am keeping my fingers and toes crossed that your suggestion would work - will definitely come back with the result.

Incidentally, after my post last night, I putty-ed into the box, "cd"ed a couple of times to get to the root, did a "ls -laRS | more", looked through literally hundreds of pages, hoping to find any GB size offending file just to get closer to the source of the gremlin, but found nothing! The only GB size file, apart from recordings, was kcore under ./proc, which did not seem to change and stayed at 2GB. I was beginning to despair...

Cheers!
 

meliam112

Newbie
Thread starter
I putty-ed into the box, "cd"ed a couple of times to get to the root, did a "ls -laRS | more", looked through literally hundreds of pages, hoping to find any GB size offending file just to get closer to the source of the gremlin, but found nothing! The only GB size file, apart from recordings, was kcore under ./proc, which did not seem to change and stayed at 2GB. I was beginning to despair...
Woah! right over my head.
I only want to watch a bit of telly ;)
 
Top