VPN Conf Importer

grog68

VIP Member
Thread starter
I was using Nord VPN on the plug in , kindly given to me by Pablo several months ago, it stopped working a few weeks back, so as I already knew, it would only work for a few months at best. so I am now trying PIA vpn, but after a week,I still cant get it working on the zgemma, just wondering if there are any problems with PIA on this plug in, I have an Android tv, so I tried the VPN on it, and it works ok, but I wanted to use on the zgemma, mainly to record from Series/thewatch, I have followed all the instructions from post 1 and I am on open atv 6.4, dont know if flashing to 6.5 would be any different, just looking for any ideas to see if I have missed something along the way, before trying some other VPNs. Message I get when trying to connect is Login error_AUTH FAILED.
All the plugin does is download the vpn config files, the vpn manager plugin starts/stops the vpn, the Auth failed error means the username/password entered is incorrect
 

grahamer67

TK Veteran
TK Supporter
All the plugin does is download the vpn config files, the vpn manager plugin starts/stops the vpn, the Auth failed error means the username/password entered is incorrect
I will have another tinker about with it over the next few days, but as I say it worked on my tv after downloading PIA onto it, cheers for the reply Grog.
 

grahamer67

TK Veteran
TK Supporter
I don't know if pia uses generated username and password I have a shared acount but pia does work with vpnmanager on openatv6.4.
Yeah, mines is a shared account aswell and I do have another username and password, which must be the generated one, just no idea on how it works.
 

dsayers2014

VIP Member
I don't know if pia uses generated username and password I have a shared acount but pia does work with vpnmanager on openatv6.4.
I don't have a login but this is on some other guides

"log in to your web account with PIA and go to control panel and generate a "PPTP/L2TP/SOCKS Username and Password"
 

grahamer67

TK Veteran
TK Supporter
Thanks mate, tried that earlier in the week, but its a shared account so couldnt do it, gonna just use the PIA on my TV and get another VPN for the zgemma.
 

urie

TK Veteran
TK Supporter
Thanks mate, tried that earlier in the week, but its a shared account so couldnt do it, gonna just use the PIA on my TV and get another VPN for the zgemma.
ok i managed to log into pia account with shared username and password so it cannot be a generated username and password for openvpn on enigma2 with vpnmanager.
 

mike123

VIP Member
TK Supporter
ok i managed to log into pia account with shared username and password so it cannot be a generated username and password for openvpn on enigma2 with vpnmanager.
I gave you a socks username and password.
 

hambone

Newbie
hi guys
i have been trying to use this plugin on my box but i am finding it difficult.
i am using vix 5.4.13 on a duo2
i have pia vpn account
i have downloaded and installed vpn manager and vpn conf importer from here
i have placed the socks username and password in a file in /tmp
when i open the vpn conf importer plugin i cansee the usernam and password and can select pia but when i press blue tosave the box crashes
maybe im doing something simple wrong?
i could possibly install the config files manually but wanted to try this plugin to basically make it simpler?
any help appreciated
thanks
ham
 

grog68

VIP Member
Thread starter
@grog68 error when trying the ipk on the first post using openvix python 3 image

View attachment 62971

I noticed only .pyo files are included it needs .py files to convert to py3. You might be able to include the cpython-39.pyc files instead but probably better with just py files
been back a couple of days but to hot to sit and look at this but will get to it when this week sometime, hopefully it will cool down a bit
 
Added 4 more VPN providers, Cactus, IVPN, ProvadoVPN and SaferVPN

There are now 18 different VPN provider options and I don't plan to look for any more myself, but if anyone wants another provider added then please let me know and I will take a look.
Hi I know this is an old post but can Norton VPN be used on h9s
 
Ok I have updated this to work with Py3 images.

I personally find that vpn manager 1.1.6 works better with python3, than the 1.1.7.py3 version (as it seems to crash for me when I press the menu button).

So I have repacked the vpn manager 1.1.6.ipk so you don't need to force install it via telnet now.

If dsayers2014 uploads the repacked vpn manager to his git, then the plugin.py can be edited to point to that file instead of the 1.1.7.py3 version.

Obviously this is just an addition to the work already done by grog68 and dsayers2014

I have tested this with both py2 and py3 images and for me it all seems to work fine, if you find issue's then please don't ask me to fix them as I am no python coder, I can just about get away with cut and paste.
 

Attachments

  • enigma2-plugin-extensions-vpnconfimporter_1.0_all.rar
    30.8 KB · Views: 10
  • enigma2-plugin-extensions-vpnmanager_1.1.6_all.rar
    451.4 KB · Views: 10

grog68

VIP Member
Thread starter
Ok I have updated this to work with Py3 images.

I personally find that vpn manager 1.1.6 works better with python3, than the 1.1.7.py3 version (as it seems to crash for me when I press the menu button).

So I have repacked the vpn manager 1.1.6.ipk so you don't need to force install it via telnet now.

If dsayers2014 uploads the repacked vpn manager to his git, then the plugin.py can be edited to point to that file instead of the 1.1.7.py3 version.

Obviously this is just an addition to the work already done by grog68 and dsayers2014

I have tested this with both py2 and py3 images and for me it all seems to work fine, if you find issue's then please don't ask me to fix them as I am no python coder, I can just about get away with cut and paste.
thanks for the update, I will test this on my box during the week and put them both on the GB feeds
 

grog68

VIP Member
Thread starter
I have updated the link in post one to the latest version of the plugin (3.60), I have not changed the version number as the changes I've made are minute, it now works on ATV 7 and also checks that a VPN has been selected, so it shouldn't blue screen.

Please let me know if you have any issues
 
Top