Vu+ Duo(not 2) lives again install guide, bootloop after skin update, can't install plugins ie e2iplayer, wooshbuild, openmultiboot, flashexpander.SSD

facey

Registered
Ok here goes....

So this box has given me a headache for a week and I have lost count of the amount of re-flashes. No sooner did I appear to achieve a goal then there would be another problem the box wouldn't install plugins, freeze up or bootloop. The most frustrating part was having everything set up, skins installed, IPTV running perfectly, then rebooting to get stuck with an endless spinner grrrrr:rage:
Once I discovered the problem, the solution was relatively simple and life was good thereafter

So the biggest issue with this box is the lack of flash memory prevenitng plugins from installing correctly to which I used the below solutions.
1. Use Openmulitboot
2. Use Flash Expander

The openmultiboot option is my preferred

I used a 16GB USB stick for this
Firstly install a preferred version of VIx or ATV, I haven't tried any of the others builds but surely they would work also
Set up this install minimally
initialise the hard drive and USB stick
Install the openmultiboot plugin
38849

run the plugin and select the USB drive for install

Now FTP into the box and you will see 2 openmultiboot folders on the usbstick
Copy the latest ATV6.3 image into the upload folder and rename the zip to something short

38851

Now go back to openmultiboot install manager on your box and install, you should now have 2 options showing on the plugin
Select openatv6.3 and reboot, the option selected here will become the default boot option that appears at every boot from now on.
(note the main install image is listed (flash))
38853

Boot into this new image and either complete the install to setup your own preferences or follow Wooshbuildsetup. If using skyWB skin and IPTV, you will need to add in the progress.png file from one of the wooshbuild help forums to "/usr/share/enigma2/SKYWB/SelectBars". This allows a long press right on the remote to open the seekbar for skipping through the VOD content, if you do not do this the skin will crash.
Once in this image it will show the flash memory as the capacity of the USB stick you have used

38854

One I was at this stage I decided to create a swapfile also, perhaps this was not required but on a low flash memory system with this magically created 14.4 GB of flash memory, surely it couldn't be bad though (this is where the Gremlins were created)

So I created 512mb swap on the hdd, set as active and enable at startup.

38855

Everything here should have been good so I thought. I had everything installed running beautifully with all the available memory and swap

38856

But no it wasn't to be, after the reboot the system failed start causing a boot loop, occasionally the blank single epg would appear then disappear and the spinner kept going. Occasionally i managed to sluggishly move through the menu or access the system via telnet. On this one magic occasion I got as far as the swap manager to make the discovery that would change the world :ROFLMAO:(y)
The swap file I had created was inactive, despite being set to enable at startup, it simply had not started and the system had ground to a halt. I recalled from a while back a method to start the swapfile from command line so quickly accessed putty and sent the command
"swapon /media/hdd/swapfile"
BOOOM! My install began working again as it should.
So there we have the issue, the swapfile was not starting on reboot.
This is where the manual method of creating a swapfile becomes useful and I re-learned about the vi editor thanks to many posts and google searching.
The solution was to simply use telnet command as below to edit the fstab file
"vi /etc/fstab"
and add the following line
"/media/hdd/swapfile swap swap defaults 0 0"
38857

Once in vi editor, go to the last digit you can press "i" to insert, then move off the last digit, return and enter the line as above.
Press escape to exit insert mode and hold shift and double press z as in zz to save and exit.
There we have it, all my issues caused by what appears to be a bug in the swapmanager.

I had tried using flashexpander plugin to help with this but ran into the same issues on reboot. Since my discovery I have tried this method again to increase the flash memory thus allowing the install of plugins such as e2iplayer with much success.

Flashepander is straight forward (I used a 2GB usb for this one)

Install latest openATV and complete basic setup
Install flashexpander plugin
38858
Run flashexpander and choose the USB stick
(note this will not show the same as the flash memory using the openmultiboot method, you will need to run flashexpander from the plugins menu and it will tell you how much flash is available.)
Once installed create the swapfile as before using the additional line in fstab to enable at startup
Now either complete your own setup or run wooshbuild install (don't forget about the progress.png file if using that skin)

For software install that should pretty much provide a usable box.
The next upgrade was to change the old mechanical drive to an SSD, this gives some performance improvemnts with EPG and any other things the HDD is being used for
I never use this box to record so cant really comment too much about it.

The SSD install was simple, remove the case screws
Remove the hdd bracket screws
Remove the old hdd screws to leave the bracket
fix the SSD using 2 or 4 PC case screws(whatever you prefer or have available)
38859
and reassemble
38860

Jobs a good un, hope this helps somebody wishing to revamp this old box.

Cheers
 
Last edited:

cactikid

VIP Member
Forum Supporter
Ahh the old duo as had one with swapfile and cacheflush enabled and also used a 8gb kingston usb,Added ram sounds interesting.
 
Top