Dsayers Picon updater

dannyyid

Registered
They changed wget in OpenATV 6.2 that was causing compression issues to scripts I was having issues with other scripts im not sure if these picon scripts where effected, but they sorted it out after 10/03/2018. So try software updates or flash image built after 10/03/2018
My image build I have installed is 2018-04-05 really strange that's it's giving this logos folder. Of course if I was to delete the logos folder and put the downloaded png image files into the picons folder it comes up, but obviously that means me doing it manually evertime I have to update the picons, which obviously defeats the point of the plugin. No worries mate, I can't get my head around it either.
 

dsayers2014

VIP Member
My image build I have installed is 2018-04-05 really strange that's it's giving this logos folder. Of course if I was to delete the logos folder and put the downloaded png image files into the picons folder it comes up, but obviously that means me doing it manually evertime I have to update the picons, which obviously defeats the point of the plugin. No worries mate, I can't get my head around it either.
Ill have a look at OpenATV 6.2 next weekend to see if I get same errors just odd that your not getting them in picon folder, you can install picons from
Code:
https://www.picons.eu/
 

dsayers2014

VIP Member
Does anyone want to test my latest Picon Updater plugin?

The plugin now has the option for SRP or SNP in the same plugin and run the picon scripts from the same source. Feel free to give me feed back on different images and skins, the plugin has been made to source most skins so the plugin should also be skinned.

You can uninstall current picon updater or leave on if you want.

Download IPK from here
Code:
https://github.com/davesayers2014/Picon/blob/master/enigma2-plugin-extensions-dsayers-piconupdater_0.2_all.ipk?raw=true
Ftp the ipk to tmp

To install the ipk

Telnet command

opkg install -force-overwrite /tmp/*.ipk

Installing via the box

Openatv

Menu... setup... software management... install local extension memory/tmp Press ok on the package press green to install.

OpenVIX
Menu > setup > VIX > Iplkg install or install local extentions then ipk installer memory/tmp Press ok on the package press green to install.

Reboot box.

####################################################################################################################

Goto plugins and press ok on Dsayers Picon Updater

You should now have the option to run SRP_Picon_Updater or SRP_Picon_Updater

Picon_Updater.jpg

Choose your option this will then remove existing picons and download picons from my github branch.

This should mean that you can have both standard picons (100x60) for most skins and large picons for skins that support XPicons ie SlykQ, SkyQ, Slyk Onyx plus more

You can still use this for standard skins that use 100x60 picons then you can delete the SkyQ folder or leave it on as it wont do any harm being there.

These plugins will download light on transparent picons as its the most natural colour to suite most skins

SNP_Picon_Updater
SNP_Picon_Updater.jpg

SRP_Picon_Updater
SRP_Picon_Updater.jpg
 
Last edited:

Chabs

TK Veteran
Does anyone want to test my latest Picon Updater plugin?

The plugin now has the option for SRP or SNP in the same plugin and run the picon scripts from the same source. Feel free to give me feed back on different images and skins, the plugin has been made to source most skins so the plugin should also be skinned.

You can uninstall current picon updater or leave on if you want.

Download IPK from here
Code:
https://github.com/davesayers2014/Picon/blob/master/enigma2-plugin-extensions-dsayers-piconupdater_0.1_all.ipk?raw=true
Ftp the ipk to tmp

To install the ipk

Telnet command

opkg install -force-overwrite /tmp/*.ipk

Installing via the box

Openatv

Menu... setup... software management... install local extension memory/tmp Press ok on the package press green to install.

OpenVIX
Menu > setup > VIX > Iplkg install or install local extentions then ipk installer memory/tmp Press ok on the package press green to install.

Reboot box.

#################################################################################################################

Before running the plugin we need to update wget thanks to kiddac for the wget update script.

(If you have previously used the other picon updater no need to use run me first script)

Download
Code:
https://github.com/davesayers2014/Picon/blob/master/run-me-first.zip?raw=true
Unzip the run-me-first.zip and send the run-me-first.sh to:

Openatv usr/script OpenVix usr/scripts

Check the script is executable 755 or 777

To run the script OpenATV Menu > infopanel > plugins > Jobmanager

OpenVIX Menu > setup > vix > script-runner

Highlight Run-me-first.sh then press ok to run

Once ran you can delete the run-me-first.sh if you want

Alternatively run the script in talnet open the run-me-first.sh copy all the text and past in talnet/putty.

####################################################################################################################

Now we can run the plugin goto plugins and press ok on Dsayers Picon Updater

You should now have the option to run SRP_Picon_Updater or SRP_Picon_Updater

View attachment 32681

Choose your option this will then remove existing picons and download picons from my github branch.

This should mean that you can have both standard picons (100x60) for most skins and large picons for skins that support XPicons ie SlykQ, SkyQ, Slyk Onyx plus more

You can still use this for standard skins that use 100x60 picons then you can delete the SkyQ folder or leave it on as it wont do any harm being there.

These plugins will download light on transparent picons as its the most natural colour to suite most skins

SNP_Picon_Updater
View attachment 32682

SRP_Picon_Updater
View attachment 32683
Nice one mate. You could have added a postinst file in your ipk to include the wget update commamd instead of downloading and running a seperate .sh file.

This would make it easy for alot of people as you know you will end up getting lods of questions on how to change file permission...

:)

Sent from my SM-G950F using Tapatalk
 

dsayers2014

VIP Member
Nice one mate. You could have added a postinst file in your ipk to include the wget update commamd instead of downloading and running a seperate .sh file.

This would make it easy for alot of people as you know you will end up getting lods of questions on how to change file permission...

:)

Sent from my SM-G950F using Tapatalk
edit I know what you mean.


This now doesn't need wget updating and the new command uses:

unset LD_PRELOAD
 
Last edited:

dsayers2014

VIP Member
Try SRP picons but it will only work if your iptv service reference matches sky. If they use a custom service reference then you'll need to see if you're provider has any.
 

donerkebab

Registered
Try SRP picons but it will only work if your iptv service reference matches sky. If they use a custom service reference then you'll need to see if you're provider has any.
Thanks Not made any difference
There were a few settings in EPG which I changed to PICONs but again nothing showing in EPG or Zap menu
 

dsayers2014

VIP Member
Sorry not sure where to check Recording and Timeshift set to /media/mmc as I am using Sd card - do I change this to media/hdd?
See if you can.

OpenATV blue button, mounts, device manager. Vix maybe in the vix menu.

Press green to setup mounts then press right to change to media/hdd then green to save and box should reboot.

Go back to mounts and check it's saved as media/hdd then try updating picons
 

donerkebab

Registered
See if you can.

OpenATV blue button, mounts, device manager. Vix maybe in the vix menu.

Press green to setup mounts then press right to change to media/hdd then green to save and box should reboot.

Go back to mounts and check it's saved as media/hdd then try updating picons
Thanks for your help - tried that took out my sdcard first but wouldnt allow me to change the mount point.....

Gave up and found a picon ipk file - that works but guess manual process to update
 

maionline

Registered
Ive seen that your implementing zeggy scripts into your builds now which include an SNP updator. Is it better than this updator? or has it just been included into a script?
 
Top