Wrong wifi driver in plugins.

RDF

Newbie
Hi
I am thinking about IPTV so I flashed to the latest Vix and my wifi lan stopped working.
I went to plugins and downloaded RTL8192CU driver (1.0-r5), the wifi adaptor is shown but will not work.

The last few times I have flashed I have downloaded RTL8192CU (1.0-r3) and the wifi has worked really well.

In plugins now there is only RTL8192CU ver 2 (1.0-r4). This does not work either.
The wifi adaptor is TP link TL-WN823N. There are TWO versions of it and I think the drivers in plugins are for version 2.
Where can I download an IPK file for RTL8192cu (1.0-r3), it used to be in plugins.
If I flash to any of my previous backups the wifi adaptor just works again.
Can I get the driver out of an image with FTP, what folder are the drivers in?

Cheers
RDF.
 

Willo3092

VIP Member
The drivers are in /lib/modules/
I would flash your backup image and copy the whole folder to your PC and then flash the new image and compare the contents of the folders.
 

RDF

Newbie
Thread starter
Hi
Thank for the heads up.
I tried to rebuild the driver folder system by replacing the driver files from the last flash image that worked and placing any RTL8192cu wifi driver files into the latest flash that won't run the wifi adaptor.
The file structure is a little different but moving the driver files that worked into the latest flash didn't work.
So, if I use a flash image from last year the wifi works fine but I have no plugins and can not download IPTV plugins.
If I flash to the latest image, the plugins does not have RTL8192CU (1.0-r3) driver I need. So no wifi to run IPTV.
Would anyone have an IPK of RTL8192cu (1.0-r3) or know wher I can download it and install it?

Cheers

RDF
 
Top