• Hi Guest, Our Xmas Raffles start this weekend. Keep checking back to take part with lots of prizes on offer on the run up to Christmas, every penny raised will go to less fortunate.

GrogBuild Openatv 6.4 v 7

Hi,

Does anyone know of a guide or website which explains the differences, benefits and negative (if any) between Openatv 6 and 7?

Many thanks
 

grog68

VIP Member
TK Supporter
ATV 7 is the latest version and I've heard 6.4 will no longer be supported from December, it doesn't mean it will stop working but there will be no software updates and some plugins are likely to stop working after that time.

As @bazcfc1 mentioned above, there are few builds that work on ATV 7 or above as there is quite a lot of work to do to make their custom plugins work on ATV 7 and it takes time which is tight for many
 

Yorkshirejok

Newbie
Thread starter
ATV 7 is the latest version and I've heard 6.4 will no longer be supported from December, it doesn't mean it will stop working but there will be no software updates and some plugins are likely to stop working after that time.

As @bazcfc1 mentioned above, there are few builds that work on ATV 7 or above as there is quite a lot of work to do to make their custom plugins work on ATV 7 and it takes time which is tight for many
Many thanks 👍
 

moshibeth

TK Veteran
TK Supporter
Best way bud as you will always run into trouble then will think to your self I shouldn’t have fekking touched it 🤣🤣
One of my motorcycles cut out last friday night so i stripped all the front end down to discover one of the ignition cables has come off. Nightmare job getting the barrel off thinking it should have gone in the garage :ROFLMAO: Hopefully the new part works and i can put it all back togetheremoji_clapemoji_clapemoji_clapemoji_clap
 

urie

TK Veteran
TK Supporter
One of my motorcycles cut out last friday night so i stripped all the front end down to discover one of the ignition cables has come off. Nightmare job getting the barrel off thinking it should have gone in the garage :ROFLMAO: Hopefully the new part works and i can put it all back togetheremoji_clapemoji_clapemoji_clapemoji_clap
Wish you all the best hope you get it sorted :smiley: at least you can still get spare parts unlike what will happen to openatv6.4 no updates available after december. Even seen members on Vix forums looking for older image versions but none available since they have changed to python 3. things move on but I must say somtimes not for the better, older plugins may not be updated.
 
Last edited:

dsayers2014

VIP Member
With ATV 6.4 will they stop feeds aswel like vix did? If they do then only backup images or builds that have everything on feeds will be ok to use
 

Willo3092

VIP Member
A fair few of the plugin authors have passed away so unless someone converts the plugins they won't work on py3 images.
Wooshbuild plugins are encrypted so they can't be updated.

Maybe the ATV team have more server space to retain old images :unsure:
 

moshibeth

TK Veteran
TK Supporter
A fair few of the plugin authors have passed away so unless someone converts the plugins they won't work on py3 images.
Wooshbuild plugins are encrypted so they can't be updated.

Maybe the ATV team have more server space to retain old images :unsure:
Looks like only your build will be left come the new year as it works on python 3 :sneaky: Will be a few switching to openvix.
 

Abu Baniaz

TK Veteran
ATV usually keep their old images working for a long time

ATV 7.0 uses OE-A 5.0 branch, python 3.9, openssl 1.1
ATV 7.1 uses OE-A 5.1 branch, python 3.10, openssl 1.3

There are a few differences with Samba and others. The kodi addons are also different too. Vix have no interest in the Kodi stuff as it adds a lot of time to the build process.

To me, the "builders" would be better off adding their fixes/changes o the plugins/images. All of Kidddacs' skins are already on the image's plugin servers.
 

grog68

VIP Member
TK Supporter
ATV usually keep their old images working for a long time

ATV 7.0 uses OE-A 5.0 branch, python 3.9, openssl 1.1
ATV 7.1 uses OE-A 5.1 branch, python 3.10, openssl 1.3

There are a few differences with Samba and others. The kodi addons are also different too. Vix have no interest in the Kodi stuff as it adds a lot of time to the build process.

To me, the "builders" would be better off adding their fixes/changes o the plugins/images. All of Kidddacs' skins are already on the image's plugin servers.
It's just time mate, I have a few plugins that need rewriting, yea skins can be updated etc, my setup script can't detect box on atv 7, as think ATV have changed the way it works as well so got to sort that
 

pabloescaban

VIP Member
TK Supporter
It's just time mate, I have a few plugins that need rewriting, yea skins can be updated etc, my setup script can't detect box on atv 7, as think ATV have changed the way it works as well so got to sort that
Can you not let them flash OA7 manually then run the GB script to install your enhancements straight after
 

Abu Baniaz

TK Veteran
What is different between your copy and kiddac's copy of his skins?

ATV have a plugin to move series to folders. If possible, can you add your changes to that plugin and make it better.

ATV are now using boxinfo and not box branding.
 

grog68

VIP Member
TK Supporter
Can you not let them flash OA7 manually then run the GB script to install your enhancements straight after
Yes, that would be the alternative, similar to how WB setup worked,

What is different between your copy and kiddac's copy of his skins?

ATV have a plugin to move series to folders. If possible, can you add your changes to that plugin and make it better.

ATV are now using boxinfo and not box branding.

1. I am using Kiddacs old skins, not changed them since beginning of GB to be honest, Only difference is I added code to use my own toppicks rather than his. Nothing major to do.

2. I think MovieOrganisor has actually been updated to be Py3 compatable, its things like the vpn conf importer and my auto abm (runs abm scan on boot) plugin that I need to fix. although the vpn conf plugin isn't part of the build so.

3. I think this was the bit that stopped me moving on lol, I didn't have the time to look into the changes that had been made to get it to work again. I just need to do a 'if boxbranding exists use that otherwise use boxinfo' so it covers users flashing from 6.4 and 7+

it will get done, but everytime I think I can spend the weekend on it the wife gives me a 'to do' list, well actually its more a 'get these jobs finished' list
 

urie

TK Veteran
TK Supporter
@grog68 , movieorganisor was upgraded to py3 but it does not work now on 7.0 or 7.1 it does not remove new prefix, also you cannot change path but not sure if that option was removed and it just uses system default movie path.
 

grog68

VIP Member
TK Supporter
@grog68 , movieorganisor was upgraded to py3 but it does not work now on 7.0 or 7.1 it does not remove new prefix, also you cannot change path but not sure if that option was removed and it just uses system default movie path.
ah ok, I didn't do the update, someone on another forum did and I didn't look at it lol, think this is another reason I sort of gave up, tried somethng and it worked but then after reflashing with new nightly build it didn't work. The ATV team do not understand the 'if it aint broke then leave the f....ing thing alone' princible lol
 

Willo3092

VIP Member
@grog68 , movieorganisor was upgraded to py3 but it does not work now on 7.0 or 7.1 it does not remove new prefix, also you cannot change path but not sure if that option was removed and it just uses system default movie path.

I've not noticed the 'new' prefix bit but my path on ViX is /media/autofs/recordings/ and that works okay.
 
Top